• Your favorite

    Apple

    ,

    iPhone

    ,

    iPad

    ,

    iOS

    ,
    Jailbreak
    , and
    Cydia
    site.
  • iPhone OS 3.1.3 Released - Jailbreakers & Unlockers: Do *NOT* Update!


    This goes without saying really, but I'm going to say it anyways as a friendly reminder. DO NOT UPDATE TO FIRMWARE 3.1.3 IF YOU ARE JAILBROKEN! It is not safe yet to do so if you want to remained jailbroken and unlocked. This advice comes straight from the DevTeam via Twitter. If your silly enough to upgrade, I've got bad news...you can no longer restore to 3.1.2 unless you have your SHSH on file in cydia.

    There may or may not be a jailbreak for 3.1.3 - the dev team will most likely wait until the major release coming for iPad and iPhone 4.0. GO TO CYDIA NOW and get your keys signed on the front page if you have not. That way you'll always at least be able to restore to 3.1.2.

    While we all like updates, this one is really nothing special and doesn't make it worthy of losing jailbreak just for it. The update includes a fix for the iPhone 3GS battery level reporting (I've never noticed any problems), a fix for app that crashed on launch (Haha really? ) and a fix for app crashes while using Japanese Kana Keyboard.

    Additional security fixes are included in this update, and can be read in more detail here: About the security content of iPhone OS 3.1.3 and iPhone OS 3.1.3 for iPod touch

    So all in all, nothing new here. My question is... When in gods name will we get 4.0? Do we have to wait till the iPad is released or what?
    This article was originally published in forum thread: iPhone OS 3.1.3 Released - Jailbreakers & Unlockers: Do *NOT* Update! started by nickhesson View original post
    Comments 604 Comments
    1. iPhone3G[S]'s Avatar
      iPhone3G[S] -
      Quote Originally Posted by dirtygermankid View Post
      I can also confirm that the new baseband is 5.12.01
      I updated because I don't use JB much, and decided to take the plunge to answer some questions.

      I was able to successfully downgrade to 3.1.2 via Saurik's widely posted methods, then use iRecovery (on Mac, didn't work in Windows) to set the auto-boot to true which took me out of recovery mode. iTunes then successfully activated and I was connected to AT&T (If you unlock, you cannot run blackra1n with hacktivation, it seems the new baseband doesn't connect It will need to be legitimately activated using an AT&T SIM [There's tons of writeups on that, doesn't have to be an iPhone SIM])

      I can say that so far I haven't had the random internet disconnects and signal loss that I did with 3.1.2 (If that's an issue to you). But, I would wait till a legit 3.1.3 Jailbreak + Unlock comes out if you don't use AT&T.

      So, currently I am running 3.1.2 Jailbroken via blackra1n on the 5.12.01 baseband with (so far) no more 3g connection issues. I am an AT&T customer, so this is a practical method for me. For everyone else, stay clear away from 3.1.3!

      Unless you seriously know what you're doing, STAY AWAY!

      (BTW, I used apples 3.1.2 signature, not the SHSH on file with cydia.. although in 2-3 more days you won't be able to do this)
      Can you test geohots unlock to see if it still works? I am certain it doesn't, just trying to figure out if it is not working because of the firmware version or if the baseband has been patched up.
    1. Poseidon79's Avatar
      Poseidon79 -
      Someone on the dev blog reported redsnow 0.9.3 will jailbreak 3.1.3 if you choose the 3.1.2 firmware. Anyone else wanna confirm?
    1. goodluck4287's Avatar
      goodluck4287 -
      My Facebook status update:

      ATTENTION: EVERYONE WITH AN IPOD OR IPOD TOUCH THAT I'VE JAILBROKEN FOR YOU, DON'T LET ITUNES UPDATE IT. IF YOU DO AND TRY TO GET MY HELP I WILL MOCK AND RIDICULE YOU AND TELL YOU THAT... go ahead and try me.
    1. dirtygermankid's Avatar
      dirtygermankid -
      Quote Originally Posted by iPhone3G[S] View Post
      Can you test geohots unlock to see if it still works? I am certain it doesn't, just trying to figure out if it is not working because of the firmware version or if the baseband has been patched up.
      Geohots current build of blackra1n does not work. I'm sure Geohot (if he's in the mood and not fighting off an army of twitter's crybabys) can easily make changes to blackra1n and all will be well, as that is also my prefered method of JB.

      I can confirm that the old bait and switch trick of IPSW's in redsn0w DOES work. No adverse effects yet.
    1. iPhone3G[S]'s Avatar
      iPhone3G[S] -
      Quote Originally Posted by dirtygermankid View Post
      Geohots current build of blackra1n does not work. I'm sure Geohot (if he's in the mood and not fighting off an army of twitter's crybabys) can easily make changes to blackra1n and all will be well, as that is also my prefered method of JB.

      I can confirm that the old bait and switch trick of IPSW's in pwnage DOES work. No adverse effects yet.
      Thanks for the info on blackra1n. I don't need the unlock, just curious!
    1. confucious's Avatar
      confucious -
      Quote Originally Posted by Poseidon79 View Post
      Someone on the dev blog reported redsnow 0.9.3 will jailbreak 3.1.3 if you choose the 3.1.2 firmware. Anyone else wanna confirm?
      Please do NOT try this if you have a 3G or 3GS.
    1. Bernie-Mac's Avatar
      Bernie-Mac -
      Will we be able to do a workaround jailbreak with redsn0w if we select 3.1.2? Can anyone confirm this?

      ^edit: nvm, thanks confucious lol
    1. Poseidon79's Avatar
      Poseidon79 -
      Quote Originally Posted by confucious View Post
      Please do NOT try this if you have a 3G or 3GS.
      How come? Seemed to work just fine back in the 3.0 to 3.0.1 days.
    1. confucious's Avatar
      confucious -
      3.0 and 3.01 had the same BaseBand.
    1. marnix1991's Avatar
      marnix1991 -
      radio radio radio !!!!!
    1. Poseidon79's Avatar
      Poseidon79 -
      Quote Originally Posted by confucious View Post
      3.0 and 3.01 had the same BaseBand.
      Shouldn't matter... redsn0w doesn't take baseband into consideration when jailbreaking.
    1. iLaw-One's Avatar
      iLaw-One -
      I honestly expected more from Apple in terms of an update....
    1. Jahooba's Avatar
      Jahooba -
      "you can no longer restore to 3.1.2 unless you have your SHSH on file in cydia"

      What does this mean? What is SHSH?
    1. frankenberrie's Avatar
      frankenberrie -
      I just updated my Jailbroken 3G to 3.1.3 and all I see is Bill Gates picture flashing on the lockscreen...

      Just kidding =)
    1. CeRTiiFieD's Avatar
      CeRTiiFieD -
      can you update to itunes 9.0.3, or does that contain the 3.1.3 firmware update!? please respond!?
    1. Mp3Supply's Avatar
      Mp3Supply -
      Quote Originally Posted by rah_nigga View Post
      i have to switch to airplane mode and back all day long. It sux
      @rah_nigga

      mine did this for a while too.. it said i had service on 3g but it wouldn't do jack squat.. i'd have to switch from airplane mode and back to get service..

      i fixed it by doing a restore to the stock firmware and re-jailbreaking.. . i tried many other methods of fixing it, and this is what worked.. so if i were you i'd try it. .. use pkgbackup and backup all your packages, and then restore and then JB and then re-download pkgbackup and reload all your packages at one shot..

      i went as far as trying to narrow it down to a package that i had installed, that i thought was causing the issue and it wasnt that..


      @Jahooba
      if you have to ask what SHSH in, and what your SHSH file is, then ... :-p

      basically, when you load up cydia, look at the top it will tell you if there is a backup of your SHSH file on the cydia server.. . you need this file IF apple ever decideds to basically try to disable users from downgrading their firmware... its basically a signature for your firmware to say its 'valid'. but none the less, its REQUIRED for a few other reasons as well..

      but to see if you have a backup of it.. . load up cyida and check the top of screen.. it will tell you if your SHSH is backed up and for what firmware's its backup for



      SHSH File Details
    1. iPhone3G[S]'s Avatar
      iPhone3G[S] -
      Quote Originally Posted by Poseidon79 View Post
      Shouldn't matter... redsn0w doesn't take baseband into consideration when jailbreaking.
      I dunno what he is going on about, it's working... I upgraded, used redsn0w to jailbreak, installed all my usual stuff from cydia, all it working just fine.
    1. sziklassy's Avatar
      sziklassy -
      Quote Originally Posted by nickhesson View Post
      My question is... When in gods name will we get 4.0? Do we have to wait till the iPad is released or what?
      The trend so far has been shortly before the next model of iPhone is released. I am not hopeful we will see it before May-ish.
    1. Mp3Supply's Avatar
      Mp3Supply -
      Quote Originally Posted by goodluck4287 View Post
      My Facebook status update:

      ATTENTION: EVERYONE WITH AN IPOD OR IPOD TOUCH THAT I'VE JAILBROKEN FOR YOU, DON'T LET ITUNES UPDATE IT. IF YOU DO AND TRY TO GET MY HELP I WILL MOCK AND RIDICULE YOU AND TELL YOU THAT... go ahead and try me.
      lol, no!! tell them TO update it and charge em 20$ each to fix it!!! prey on the weak! :-p
    1. confucious's Avatar
      confucious -
      Quote Originally Posted by iPhone3G[S] View Post
      I dunno what he is going on about, it's working... I upgraded, used redsn0w to jailbreak, installed all my usual stuff from cydia, all it working just fine.
      I had it on very good authority that it wouldn't work. It's not the same as the 3.0->3.01 upgrade but I'm trying to find out what's happening.

      Still investigating:
      MuscleNerd

      LOL iPhone 2G experimenters can go ahead & use yesterday's redsn0w on today's 3.1.3 just point it at 3.1.2 ipsw (2G only for now!)