• Your favorite

    Apple

    ,

    iPhone

    ,

    iPad

    ,

    iOS

    ,
    Jailbreak
    , and
    Cydia
    site.
  • iPhone OS 3.1.3 Released - Jailbreakers & Unlockers: Do *NOT* Update!


    This goes without saying really, but I'm going to say it anyways as a friendly reminder. DO NOT UPDATE TO FIRMWARE 3.1.3 IF YOU ARE JAILBROKEN! It is not safe yet to do so if you want to remained jailbroken and unlocked. This advice comes straight from the DevTeam via Twitter. If your silly enough to upgrade, I've got bad news...you can no longer restore to 3.1.2 unless you have your SHSH on file in cydia.

    There may or may not be a jailbreak for 3.1.3 - the dev team will most likely wait until the major release coming for iPad and iPhone 4.0. GO TO CYDIA NOW and get your keys signed on the front page if you have not. That way you'll always at least be able to restore to 3.1.2.

    While we all like updates, this one is really nothing special and doesn't make it worthy of losing jailbreak just for it. The update includes a fix for the iPhone 3GS battery level reporting (I've never noticed any problems), a fix for app that crashed on launch (Haha really? ) and a fix for app crashes while using Japanese Kana Keyboard.

    Additional security fixes are included in this update, and can be read in more detail here: About the security content of iPhone OS 3.1.3 and iPhone OS 3.1.3 for iPod touch

    So all in all, nothing new here. My question is... When in gods name will we get 4.0? Do we have to wait till the iPad is released or what?
    This article was originally published in forum thread: iPhone OS 3.1.3 Released - Jailbreakers & Unlockers: Do *NOT* Update! started by nickhesson View original post
    Comments 604 Comments
    1. black_orchid's Avatar
      black_orchid -
      Not yet. I'm scared to update to see if that would fix it. I never do anything without checking on this forum.

      Quote from black_orchid
      question, my MMS quit, is it because of the apple update? I know it's a retarded question, but I am retarded, lol
      did you update to 3.1.3?
    1. KartRacer's Avatar
      KartRacer -
      I've not had one single app crash on me in a long time. 3.1.2 is very stable. Hopefully 4.0 or whatever it'll be really kicks android in the nuts, and a screaming fast new iPhone will keep me on AT&T even though I hate them.
    1. Bernie-Mac's Avatar
      Bernie-Mac -
      So all we have to do is upgrade to 3.1.3, and then use ultrasn0w like as if we were on 3.1.2?
    1. confucious's Avatar
      confucious -
      No!
      UltraSn0w does not work with the new BB nor does BlackSn0w.

      Confirmed RedSn0w does work with 3.12 ipsw if you update to 3.13 on 2G or 3G iPhones but no unlock.

      For 3GS there's currently no way to inject an exploit into unpwned (i.e. DFU mode doesn't work for it)so will not work.

      Do not try this if you want a software unlock.
    1. Grassmasta's Avatar
      Grassmasta -
      Do you guys remember when updates were actually worth taking a day to re-jailbreak and download all your Cydia apps again? I haven't even bothered to update since 3.0... Tell me if I'm missing something super cool...
    1. xxhorseriderxxx's Avatar
      xxhorseriderxxx -
      blah =\ why'd Apple go and f- up the perfectly good jailbreak environment we had goin'? =[
    1. gthugballin's Avatar
      gthugballin -
      meh.
    1. xxhorseriderxxx's Avatar
      xxhorseriderxxx -
      Quote Originally Posted by Grassmasta View Post
      Do you guys remember when updates were actually worth taking a day to re-jailbreak and download all your Cydia apps again? I haven't even bothered to update since 3.0... Tell me if I'm missing something super cool...
      3.1.2 is good for the new genius features, copy/paste functionality (videos, phone numbers), and augmented rešlity apps. (not to mention that usually developers require the newest firmware for their apps nowadays when new ones are released).
    1. battlecrushr's Avatar
      battlecrushr -
      i bet therell be a lot of people that update anyways and then come here and ask for help.

      and so does this mean even 3g users need to have shsh on cydia too.
    1. Melech518's Avatar
      Melech518 -
      Oh course there will be. They always update and then come and ask for help....It is like the norm around here
    1. darksoul01's Avatar
      darksoul01 -
      he post that just for fun but i really updated it to new OS
      and ....... anyone any solution how cani get back my rock app and cydia ...
      thanx
    1. battlecrushr's Avatar
      battlecrushr -
      serioud?
      well rite now no
    1. Bernie-Mac's Avatar
      Bernie-Mac -
      Quote Originally Posted by confucious View Post
      No!
      UltraSn0w does not work with the new BB nor does BlackSn0w.

      Confirmed RedSn0w does work with 3.12 ipsw if you update to 3.13 on 2G or 3G iPhones but no unlock.

      For 3GS there's currently no way to inject an exploit into unpwned (i.e. DFU mode doesn't work for it)so will not work.

      Do not try this if you want a software unlock.

      Crap my bad, i mean redsn0w and not unltrasn0w, i just get them mixed up all the time.
    1. confucious's Avatar
      confucious -
      Quote Originally Posted by darksoul01 View Post
      he post that just for fun but i really updated it to new OS
      and ....... anyone any solution how cani get back my rock app and cydia ...
      thanx
      What phone? 2G or 3G just run RedSn0w 0.92 pointing at 3.12 ipsw - but why on earth do you want Rock?
    1. battlecrushr's Avatar
      battlecrushr -
      rock is awesome
    1. @pple_nrd's Avatar
      @pple_nrd -
      Has Blackra1n the same issue? (don't need unlockin)
      Someone tested??

      Or is this the same like RedSn0w when upgrading to 3.1.3?
    1. tsatryan's Avatar
      tsatryan -
      Quote Originally Posted by darksoul01 View Post
      he post that just for fun but i really updated it to new OS
      and ....... anyone any solution how cani get back my rock app and cydia ...
      thanx
      DING DING DING DING DING DING!!!!!!
      We have a WINNER!
      First to post after ignoring the don't upgrade notices!
      I'm sure it won't be the last.
    1. confucious's Avatar
      confucious -
      Quote Originally Posted by @pple_nrd View Post
      Has Blackra1n the same issue? (don't need unlockin)
      Someone tested??

      Or is this the same like RedSn0w when upgrading to 3.1.3?
      BlackRa1n will not work.
    1. TOBERMORAY's Avatar
      TOBERMORAY -
      I have just updated my IPhone 3G to 3.1.3 without knowing it, I used Redsnow and pointed it to a 3.1.2 Restore ipsw and and its unlocked. I have installed my usual software from Cydia and all works ok.
    1. battlecrushr's Avatar
      battlecrushr -
      well u have a 2g rite