• Your favorite

    Apple

    ,

    iPhone

    ,

    iPad

    ,

    iOS

    ,
    Jailbreak
    , and
    Cydia
    site.
  • purplera1n RC2 out for Win & OSX!
    geohot has released the second revision of his windows iPhone 3GS jailbreak. This one includes:
    • Vista, Windows 7, International, 64-bit support
    • Less flakiness in the payload
    • Cydia tar cleaned up
    • Improved logging with slightly more useful errors
    • New kernel patches, codesign errors gone. Props posixninja
    • Added vm_map +x, passed vm_check
    • No winterboard yet, but now that ball is in Saurik's court :-)
    • Still in beta, use caution
    You can download from purplera1n.com. Usage is the same so just follow our guide (windows) OR our OS X guide.

    7/5 UPDATE: Mac version of purplera1n now available for download!
    This article was originally published in forum thread: purplera1n RC2 out for Win & OSX! started by Cody Overcash View original post
    Comments 314 Comments
    1. reeko's Avatar
      reeko -
      Quote Originally Posted by finalfantasy View Post
      DONE.... 3 hours too take apart my old iphone 3g and put it back together... and only problem is the power button feels odd so i might of not put it back 100% but it still works lol
      Yo, exactly the same. I never got the home button on properly i dont think its possible, the fit of the third party case is just crap. And the case broke when i dropped my phone so had to go back to the black OEM
    1. SharpieBandit's Avatar
      SharpieBandit -
      Yeah I'm just not gonna take my iPhone apart.
    1. finalfantasy's Avatar
      finalfantasy -
      lol well after playing with the 3g i noticed something.... the HOME BUTTON doesnt work lol.... the power button works but lets say i click on safari. then i want too go back too the main screen i hit the home button and NOTHING... the button isnt doing anything... any suggestions? lol flex cable 1 2 3 and 4 all seem too be plugged in properly and i unpluged them and repluged them back in and still the home button doesnt do anything
    1. 7lowe's Avatar
      7lowe -
      Quote Originally Posted by thu6 View Post
      I have a question for you guys using Backgrounder.

      Hows this not interfere with 3GS's phone commands when holding down the Home button ?
      Hold on the lock screen or home screen and you get Voice Control. Hold in an app and you enable/disable Backgrounding. Keep holding another second or so and then you get Voice Control.

      7
    1. finalfantasy's Avatar
      finalfantasy -


      thats the iphone 3g i have all in pieces lol... top corner are all the screws lol...

      but now the home button doesnt work and i cant figure out what i did too make it not work lol
    1. ferdie's Avatar
      ferdie -
      sygic gps is out available at the appstore...priced at $79.99
    1. lild7hina's Avatar
      lild7hina -
      i had the same problem when i swapped mine... just had to make sure the dock connector part was aligned properly and that the screen was pushed in all the way... and also made sure my screws went in all the way (the first two you take out) that did the trick for me
    1. hydroabiscuit's Avatar
      hydroabiscuit -
      my wifi and t-mobile signal keep dropping...when i make a call to my voicemail and type in a button like "7", i hear no tone...should i just JB and avoid ultrasn0w?

      UPDATE:
      1. i uninstalled ultrasn0w fearing some potential damage to the iphone
      2. turned it off
      3. removed the t-mobile sim while off
      4. re-inserted the stock ATT sim incase i need to restore
      5. turned the phone back on in airplane mode and left it alone

      i'm going to wait 'till dev team fixes untrasn0w...patience is a virtue and i dont want to ruin my investment
    1. finalfantasy's Avatar
      finalfantasy -
      yes t-mobile customers seem too have the only issues with dropped calles and wifi with jb so far

      so ultrasnow bad if your jb and with tmobile
    1. foureight84's Avatar
      foureight84 -
      Quote Originally Posted by hydroabiscuit View Post
      my wifi and t-mobile signal keep dropping...when i make a call to my voicemail and type in a button like "7", i hear no tone...should i just JB and avoid ultrasn0w?

      UPDATE
      Change carrier from automatic to Tmobile. Turn off and turn on your phone, let it go idle for a couple of minutes and it should work.
    1. hydroabiscuit's Avatar
      hydroabiscuit -
      Quote Originally Posted by foureight84 View Post
      Change carrier from automatic to Tmobile. Turn off and turn on your phone, let it go idle for a couple of minutes and it should work.
      turn off as in power off? or turn off as in pushing the sleep button?
    1. foureight84's Avatar
      foureight84 -
      Quote Originally Posted by hydroabiscuit View Post
      turn off as in power off? or turn off as in pushing the sleep button?
      turn it off. reboot it. and let it sit for a few minutes. it should lock on to tmo by then.
    1. Vaddy's Avatar
      Vaddy -
      Quote Originally Posted by itaintrite View Post
      Yup, it's Ultrasn0w. It broke not just my Wifi but also Cydia.
      I think I found a fix to the ultrasn0w=no Wi-Fi for T-Mobile USA users, make sure 3G is turned off (obviously) install bossprefs or sbsettings and fix user dir permissions then reboot and you should be good to go, worked for me
    1. ninthchamber99's Avatar
      ninthchamber99 -
      Quote Originally Posted by ninthchamber99 View Post
      I decided to take the plunge. I can report that all went great. Jailbroke the phone in less than 2 minutes. I will report any issues I have. The biggest hurdle I had to clear was I could not upgrade iTunes to 8.2 (I was on 8.1 for the longest time).

      Edit: I have Cydia installed, everything is working great.
      Update: I tried to install iRealSMS through Cydia and the phone locked up. Then it went into safe mode after displaying a message that the springboard crashed. I am restoring and re-doing the entire process.

      Update #2: Also, I installed Snapture and no picture appeared on screen, only a black screen. I snapped a picture, it made the "camera taking picture sound" but no image was available for review. I have not been keeping up with what apps work through cydia but these two appear so far not to be working correctly for me. We will see after attempt #2.
    1. dont h8 dre's Avatar
      dont h8 dre -
      Ok i have been able to get ultrasn0w to work properly on my iPhone the only problem i have is when i reset the device. If i were to power it down and then back up again i no longer able to be on tmobile to even check voicemail. I have tried the fix permissions as well. No go.
    1. SharpieBandit's Avatar
      SharpieBandit -
      Quote Originally Posted by dont h8 dre View Post
      Ok i have been able to get ultrasn0w to work properly on my iPhone the only problem i have is when i reset the device. If i were to power it down and then back up again i no longer able to be on tmobile to even check voicemail. I have tried the fix permissions as well. No go.
      Did you turn 3G off before running Ultrasn0w?
    1. hydroabiscuit's Avatar
      hydroabiscuit -
      well after some time with purplera1n, here are my findings:
      1. ultrasn0w drops the signal repeatedly for t-mobile...so to not risk damage, i uninstalled it
      2. wifi works very weak even when i'm next to my hotspot, this is after the jailbreak...with the stock firmware, it works beautifully.

      i applaud geohot for his efforts in delivering a timely JB for the iphone 3GS...for me it was a lot of fun to take the plunge and tinker around with beta software .

      But until theres a bug-free version of purplera1n or dev team's software that will fix the wifi and ultrasn0w, i'll be sticking to using my 32gig 3GS as an "ipod touch" (via the stock firmware and airplane mode) and just wait patiently
    1. Cer0's Avatar
      Cer0 -
      Did anyone notice a battery time increase since jb? Since I got my phone I would wake up around 3, go to work, by 11ish the battery would be at 30%. Then I would come home about 1-2 and the battery would be warning me about 20%. I jb'd last night and got up at noon to go to baseball game and it is now almost 1 am and I am only at 50%. I used it more today than a regular day. The only other thing that happened last night was I let it die completely, to the point it powers itself.
    1. equlizer's Avatar
      equlizer -
      I mostly like the jailbreak becuase i can turn off 3g and edge and shut down everything else i dont need in 1 swipe. After doing that, i notice i get at least another hour or more of usage.
    1. foureight84's Avatar
      foureight84 -
      I don't see any reason why it would be harmful to have ultrasn0w on. I'm not getting dropped calls like you guys are experiencing, just slow connection time when i restart.

      hopefully this competition between geohot and the dev team will result in a real unlocker for 3gs.