• Your favorite

    Apple

    ,

    iPhone

    ,

    iPad

    ,

    iOS

    ,
    Jailbreak
    , and
    Cydia
    site.
  • purplera1n RC2 out for Win & OSX!
    geohot has released the second revision of his windows iPhone 3GS jailbreak. This one includes:
    • Vista, Windows 7, International, 64-bit support
    • Less flakiness in the payload
    • Cydia tar cleaned up
    • Improved logging with slightly more useful errors
    • New kernel patches, codesign errors gone. Props posixninja
    • Added vm_map +x, passed vm_check
    • No winterboard yet, but now that ball is in Saurik's court :-)
    • Still in beta, use caution
    You can download from purplera1n.com. Usage is the same so just follow our guide (windows) OR our OS X guide.

    7/5 UPDATE: Mac version of purplera1n now available for download!
    This article was originally published in forum thread: purplera1n RC2 out for Win & OSX! started by Cody Overcash View original post
    Comments 314 Comments
    1. romeoz's Avatar
      romeoz -
      Im running Vista....I hit make it rain and thats it..nothing else happenes to my phone...been 3 hours now...did it twice..it wont see my phone for some reason
    1. roly01's Avatar
      roly01 -
      ive tried with itunes open and with itunes closed, restarted my computer 3 times and nothing. btw i already had it jailbroken from the original purplera1n. and im running vista

      also i dont know if this means anything but as soon as it says done, wait for reboot i hear my phone disconect from my computer but it just stays on the same screen with the picture
    1. SharpieBandit's Avatar
      SharpieBandit -
      Quote Originally Posted by romeoz View Post
      Im running Vista....I hit make it rain and thats it..nothing else happenes to my phone...been 3 hours now...did it twice..it wont see my phone for some reason

      Have iTunes open when you start purplera1n. If you make it to Recovery mode, do a hard reset and see if it bumps you to the purplera1n screen. Power+home.
    1. finalfantasy's Avatar
      finalfantasy -
      what did i miss? sorry been spending the last hour taking appart my old iphone 3g lol..... 1/10 of the way putting it back together now lol... "practicing so when i get my new blue back cover for the 3gs i can replace that ugly White back with a blue one
    1. SharpieBandit's Avatar
      SharpieBandit -
      Quote Originally Posted by roly01 View Post
      ive tried with itunes open and with itunes closed, restarted my computer 3 times and nothing. btw i already had it jailbroken from the original purplera1n. and im running vista

      also i dont know if this means anything but as soon as it says done, wait for reboot i hear my phone disconect from my computer but it just stays on the same screen with the picture

      Try a hard reset and see if it helps when you get stuck at the purplera1n screen. And what version of iTunes are you using? IT should be 8.2.0.23. Make sure you have the RC2 release of purplera1n.


      Quote Originally Posted by finalfantasy View Post
      what did i miss? sorry been spending the last hour taking appart my old iphone 3g lol..... 1/10 of the way putting it back together now lol... "practicing so when i get my new blue back cover for the 3gs i can replace that ugly White back with a blue one
      I can only tell you what you missed if you tell me what you know.
    1. 7lowe's Avatar
      7lowe -
      Original purplera1n worked for me on the 2nd try (XP). I tried RC2 over it and just kept getting stuck and "Done...wait for reboot" and then would force a reboot and still be in recovery mode.

      Gave up and restored to fresh 3.0 and then tried RC2 and it worked like a charm.

      7
    1. ca3's Avatar
      ca3 -
      ive tried everything also, with and without itunes opened.... it wont work...
    1. roly01's Avatar
      roly01 -
      ive opened purplera1n with itunes open and i just get the same results. just tried a restore and keep getting error 14. and when i do a hard reset from restore mode it just goes back to restore no purplera1n screen the only way i can get to the purplera1n screen is when i use the program

      i have the latest version of itunes and purplera1n rc2 but nothing
    1. finalfantasy's Avatar
      finalfantasy -
      Sharpie, i know that i can easlily take appart the iphone 3g. i know its hard too put it back together. hoping too have a BLUE back for the iphone 3gs instead of WHITE since i find the White too get dirty and ugly after ... an hour loll.....
    1. SharpieBandit's Avatar
      SharpieBandit -
      Quote Originally Posted by finalfantasy View Post
      Sharpie, i know that i can easlily take appart the iphone 3g. i know its hard too put it back together. hoping too have a BLUE back for the iphone 3gs instead of WHITE since i find the White too get dirty and ugly after ... an hour loll.....
      Well the 3GS is jailbroken now.

      I have a white iPhone 3GS. I've had it since launch at 7 in the AM and there's not a dirty spot on it. I have only one scratch. 1/8 inch long one right in the middle of the Apple on the back.
    1. foureight84's Avatar
      foureight84 -
      has anyone compared edge speed on the 3g/3gs against the 2g? it seems slower. i was averaging 200 ~ 230 kbs, now i'm getting 50.
    1. Magnum's Avatar
      Magnum -
      idk,...when mine was stuck in recovery, i closed purple rain, opened itunes, and when it recognized my phone it said it musg be restored...so i hit ok and closed itunes and hit make it rain again and it finished....
    1. roly01's Avatar
      roly01 -
      wow im stuck, im trying dfu mode now hope it works

      no luck fml
    1. Vaddy's Avatar
      Vaddy -
      Anyone here on T-Mobile USA use purplerain RC2 and as a result now has a solid T-Mobile signal with Wi-Fi working???? I'm having troubles keeping my reception for both after reboots and I also went to carrier settings and selected T-Mobile instead of automatic....
    1. foureight84's Avatar
      foureight84 -
      btw, mms works on tmobile with the iphone. i tested earlier.

      Quote Originally Posted by Vaddy View Post
      Anyone here on T-Mobile USA use purplerain RC2 and as a result now has a solid T-Mobile signal with Wi-Fi working???? I'm having troubles keeping my reception for both after reboots and I also went to carrier settings and selected T-Mobile instead of automatic....
      Yea i had problems with this. It's not purplera1n. i think it's ultrasn0w that might be causing this. I had to reboot a couple of times. I also notice that it helps if you let the phone go idle when rebooting for a couple of minutes. (mine is manual set to tmo too. can't get to lock on to tmo on automatic).
    1. finalfantasy's Avatar
      finalfantasy -
      DONE.... 3 hours too take apart my old iphone 3g and put it back together... and only problem is the power button feels odd so i might of not put it back 100% but it still works lol
    1. thu6's Avatar
      thu6 -
      I have a question for you guys using Backgrounder.

      Hows this not interfere with 3GS's phone commands when holding down the Home button ?
    1. esoin's Avatar
      esoin -
      THANKS GeoHotz! you da man!

      WinXP SP3, 3GS
    1. itaintrite's Avatar
      itaintrite -
      Quote Originally Posted by foureight84 View Post
      btw, mms works on tmobile with the iphone. i tested earlier.



      Yea i had problems with this. It's not purplera1n. i think it's ultrasn0w that might be causing this. I had to reboot a couple of times. I also notice that it helps if you let the phone go idle when rebooting for a couple of minutes. (mine is manual set to tmo too. can't get to lock on to tmo on automatic).
      Yup, it's Ultrasn0w. It broke not just my Wifi but also Cydia.
    1. Araya213's Avatar
      Araya213 -
      Quote Originally Posted by finalfantasy View Post
      DONE.... 3 hours too take apart my old iphone 3g and put it back together... and only problem is the power button feels odd so i might of not put it back 100% but it still works lol
      Oooh let us see some pics!