• Your favorite

    Apple

    ,

    iPhone

    ,

    iPad

    ,

    iOS

    ,
    Jailbreak
    , and
    Cydia
    site.
  • iMovie Ported: Works Great on the iPhone 3GS
    [ame]http://www.youtube.com/watch?v=N6L07nPrjzo[/ame]



    Ok Steve, stop holding it back. We want iMovie on our iPhone 3GS. We didn't upgrade just to be left in the dust. We still have video, there is no reason that iMovie shouldn't work on the 3GS, besides the slower rendering. Come on Steve! Why are you holding out on us.

    Well Steve, if you won't do it, someone else will. An upstanding fellow by the name of David Romhan Torres, has managed to "port", more correctly put, modified, the iMovie app to work on the iPhone 3GS. And guess what? It actually works just fine.

    David Says it's simple.
    "just download the file, modify info.plist file and change the Minimum system version to 3.0.0 and UIRequiredDeviceCapabilities/front-facing-camera to false"
    Taimur from Redmondpie, has put together the video above to demonstrate what David has done. As you watch the video, you can see that the application works just fine. Ok so you can't export an HD video, but that's should be clear as day, because the iPhone 3GS doesn't record HD, so obviously that won't work. But you can still edit, make transitions, and export the final product just fine.

    Apparently you can do this on a 3.1.x firmware as well. It requires a modified .ipa file, which breaks Apple’s DRM so unfortunately you won't be getting any instructions from us, or where to find it. That's up to you. And please do NOT post links to the ipa here. Juts enjoy the fact that it's been done and is out there somewhere for you to enjoy.

    Although, I must conclude by saying, all of this bothers me just a slight bit, and at the same time makes me comforted. If indeed, iMovie can run from a modified ipa no problem, then perhaps Apple DOES still have plans for an iMovie compatible, and all they wanted to do was focus on the iPhone 4 first because it has HD. That would be fantastic, however, if that wasn't the case, it just drive me nuts that Apple would hold this fantastic product back.
    This article was originally published in forum thread: iMovie Ported: Works Great on the iPhone 3GS started by nickhesson View original post
    Comments 73 Comments
    1. katmeef's Avatar
      katmeef -
      Quote Originally Posted by reanimationxp View Post
      Also having this issue on 3.1.3, 3GS. What's the correct way to edit?

      Also, can this be done with iBooks to get it running on 3.1.3?
      Same here, I could get it to install on 3.1.3 after plist modification but it only crashed after starting the app.
    1. rocky1285's Avatar
      rocky1285 -
      anybody plzz put one copy plzzzzzzzzzzz
    1. ocojaa's Avatar
      ocojaa -
      Same thing here, exits to springboard for me on 3.1.3.
    1. Hagow's Avatar
      Hagow -
      Does your iPhone need to be jailbroken? Can I paid for the app edit the plist then sync it without jailbreaking?
    1. Eagleye's Avatar
      Eagleye -
      Quote Originally Posted by katmeef View Post
      Same here, I could get it to install on 3.1.3 after plist modification but it only crashed after starting the app.
      Mine starts up too after installing but crashes within a second. Gonna keep playing with the plist and see if I can find anything. (3.1.2 3g[S])
    1. lilmikey's Avatar
      lilmikey -
      what about minimum os version?

      can u just upload the app because it wouldnt let me put it into itunes idk what i did wrong
    1. drbsky's Avatar
      drbsky -
      I had no problem downoading iMovie on my 3GS. I was surprised when i found it in the app store because i thought that it was only available on the iPhone 4.
    1. kwall's Avatar
      kwall -
      hmm this is interesting stuff.
    1. EddieLeonard's Avatar
      EddieLeonard -
      Quote Originally Posted by kwall View Post
      hmm this is interesting stuff.
      what happened to the long post?
    1. reaves205's Avatar
      reaves205 -
      Simple for you,,, Share???
    1. anieto's Avatar
      anieto -
      guess there's some kind of problem on 3.1.3. I can't get it to work either. I've already changed the permissions to 0755 and nothing works
    1. seven77's Avatar
      seven77 -
      nice thanks for the info !!!!

      Quote Originally Posted by anieto View Post
      guess there's some kind of problem on 3.1.3. I can't get it to work either. I've already changed the permissions to 0755 and nothing works
      did u change the frontcamerause from true to false ?
    1. tekwiz's Avatar
      tekwiz -
      I got it installed on my ipad but it crashes upon launch, I believe this is because both the owner and other setting are set to mobile instead of root/wheel or whatever the normal ownership is.
    1. robertr1's Avatar
      robertr1 -
      Hmm interesting. From what I've read it doesn't seem to be working on 3.1.3. Has anyone got it to work on an iphone 3gs with firmware 3.1.3?
    1. StealthBravo's Avatar
      StealthBravo -
      Got GameCenter on my iPhone 4

    1. JonnyBoy123's Avatar
      JonnyBoy123 -
      First the multitasking and now iMovie! I hope other .apps can be ported to older models later on.
    1. Testjockey's Avatar
      Testjockey -
      I have it running on iphone 3g but when I select record from camera it closes any sugestions for changes to the plist
    1. JonnyBoy123's Avatar
      JonnyBoy123 -
      @testjockey I noticed the same thing with video recording on the 3G! Cycorder from Cydia crashes everytime I open it. Cycorder worked perfectly on 3.1.2 so is it possible that Apple could have fixed the recording in iOS 4.0?
    1. Testjockey's Avatar
      Testjockey -
      I dont think Cycorder has been updated yet to work with ios4 yet.

      If imovie can run under 3g iso4 then there has to be a setting for cammera minimum capabilities?
    1. JonnyBoy123's Avatar
      JonnyBoy123 -
      @testjockey, it should be possible to get the video to work because it was able to perform everything else but the video. Maybe something else needs to be changed in the Info.plist as well?