• Your favorite

    Apple

    ,

    iPhone

    ,

    iPad

    ,

    iOS

    ,
    Jailbreak
    , and
    Cydia
    site.
  • Jailbreaking & Unlocking iOS 4 : What You Should Know
    Note: This Post will be udpated as news becomes available. Please share your experiences in this thread. It is highly suggested you do not update to iOS 4 right away. Please be patient.



    Today, as expected, Apple released iOS 4 to the public. But before you get too excited, there are some things you should know before updating to iOS 4. If you want to play Jailbreak with your iDevice, make sure you read through this.

    iOS 4 is compatible with the 3G, 3GS, the newest iPod Touch and iPhone 4. Those of you that have played with the GM release, the build number on this public release is exactly the same; 8A293. So as for changes since the GM there are none in this release.

    Update:
    Quote Originally Posted by bennyg View Post
    there are actually differences in the GM and public release. Notice no game centre in the public release? Also if you go to http://oo.apple.com to opt out of the iAd data collection stuff on the GM release it states your not on iOS4!

    Jailbreaking

    iPhone3GS & iPod3G owners (especially if you used Spirit for your first JB) should stay away from iOS4 for now

    Wizdaz has kept the community in the know, informing us that PwnageTool is currently being updated as we speak. PwnageTool 4.0 will support the iPhone 3G (with Pwnage exploit), iPhone 3GS and iPod Touch 2G (both with 24kPwn exploit). Keep in mind this means no support for the newer bootom. Remember the tethered days? If that was you, then you will need to wait until Spirit is updated or a new tool is updated for such.

    There is of course the Redsn0w option if you have a 3G, but stay away from any custom packages. The Dev-Team has written it well, and because of their credibility, here is exactly what they say

    We are working hard on a release to our tools that will jailbreak your device (or give you iOS 4 via the jailbreak train) and provide you with a carrier unlock.

    Until these tools are released you should hold off on updating your device until we have fully tested our tools with all the relevant devices.

    If you rely on hacktivation or a carrier unlock (ultrasn0w) then you should not upgrade until we have fully tested and released our tools.

    Don’t be tempted with unofficial PwnageTool/redsn0w bundles or releases, just check here or our team twitter for real time release information.

    Remember, we risk our devices so you don’t have to (but this time anyone who has made a mistake upgrading their baseband firmware at 3.1.3 or 4.0 should be OK real soon Now!
    iPhone Dev-Team
    WizDaz


    Unlocking iOS 4

    The iPhone Dev Team has released ultrasn0w 0.93 for unlocking your new iOS 4. Simply add the Cydia repo: repo666.ultrasn0w.com. This version of ultrasn0w will unlock basebands 04.26.08 thru 05.13.04. If your unsure, that means that ultrasn0w unlocks ALL basebands since iPhone OS 3.1. Even more specifically, 04.26.08, 05.11.07, 05.15.01, and 05.13.04. Remember to disable 3G on T-Mobile USA.

    So on the unlocking front, you're pretty much golden. However it's still recommend to wait just a little bit longer before making the plunge for iOS 4.

    iPhone Dev-Team
    MuscleNerd
    This article was originally published in forum thread: Jailbreaking & Unlocking iOS 4 : What You Should Know started by nickhesson View original post
    Comments 470 Comments
    1. klonaton's Avatar
      klonaton -
      has it been confirmed redsn0w currently does not support the 3GS?
    1. Buckmaster's Avatar
      Buckmaster -
      For you guys that know what is what. My iphone 3g was JB with Spirit, modem filmware at 05.12.01 . Will I be able to update to 4.0, and unlock my phone?
      I preordered a iphone 4, and was wanting to unlock my 3G phone, to give my son to use. Any info would be great.
    1. inc188's Avatar
      inc188 -
      just to confirm... i have itouch 2g and i upgraded to 4.0... am i ok to jailbreak it? if so, what should i use?

      the first time i did it i used blackra1n, but i am assuming that wont work with 4.0

      please let me know

      thanks
    1. jluzbet's Avatar
      jluzbet -
      0.9.5b5-3 is out should take care of the above... 3gs on hold...
    1. gafu's Avatar
      gafu -
      In reality guys,many of you ate asking questions that by doing a simple SEARCH you'd find.It really doesn't take that long to find the answer you're looking for.I've been here for a while,haven't posted alot because the search button is my friend.....
    1. eZStaR's Avatar
      eZStaR -
      I had game center on the GM version.... A matter of fact, I can post a screen shot up right now if some 1 wants proof.
    1. delic13's Avatar
      delic13 -
      Quote Originally Posted by Rinnycoop121 View Post
      Why do we need to disable 3G service when unlocking
      You can't get 3G on tmobile with an ATT phone. If you don't disable 3G the. The phone will just search and search and search for a 3G signal using allot of battery. Tmobile uses a 1700 band for 3G service, ATT uses 850 for 3G. You will not get 3G on tmo service. It's a hardware restraint.
    1. ziggie216's Avatar
      ziggie216 -
      redsn0w is out, probably beta.. but I was wondering, for 3G [not 3GS] is there any point of keeping modem firmware at 04.26.08?
    1. louort3's Avatar
      louort3 -
      Thanx dev team!!!!
    1. moon#pie's Avatar
      moon#pie -
      never mind
    1. jabregousmc's Avatar
      jabregousmc -
      Quote Originally Posted by jluzbet View Post
      0.9.5b5-3 is out should take care of the above... 3gs on hold...
      this is correct. use the beta 5-3 for your iphone 3g or ipt 2g. 3gs still waiting! i'm sure it'll be out pretty quick tho!

      a side question though. has any other 3g owners notice that the official fw runs slower than the GM?? mine seems a lot laggier than the GM i was running before getting the official 4.0. what tha dilly yo??
    1. XFaega's Avatar
      XFaega -
      Quote Originally Posted by Buckmaster View Post
      For you guys that know what is what. My iphone 3g was JB with Spirit, modem filmware at 05.12.01 . Will I be able to update to 4.0, and unlock my phone?
      I preordered a iphone 4, and was wanting to unlock my 3G phone, to give my son to use. Any info would be great.
      OK Do this -
      1. ( Make sure you backed up and synced all your info ) Go to setting - General - Reset - Erase All Content and Settings
      2. After that you will need iTunes 9.2 and then download iOS4 and install
      3. You will need redsnow .095b5-3 and iOS4 GM
      4. Run redsnow .095b5-3 and point it to iOS4 GM to jailbreak your 3G iPhone
      5. Now update Cydia
      6. Add resource repo666.ultrasn0w.com for Yellowsn0w for unlocking

      That should be it.
    1. jabregousmc's Avatar
      jabregousmc -
      Quote Originally Posted by ziggie216 View Post
      redsn0w is out, probably beta.. but I was wondering, for 3G [not 3GS] is there any point of keeping modem firmware at 04.26.08?
      the beta 5-3 unlocks pretty much ALL basebands now! so you can unlock up to the 05.13.04 w/ ultrasn0w 0.93!
    1. mbeezy81's Avatar
      mbeezy81 -
      NICE!!! I upgraded to IOS4 earlier just to get the feel of it. I've been downgrading iTunes and my firmware back to 3.1.3 for the past 2 hours, jailbroke and ---UNLOCKED--- my 3G... Bout freaking time we get to unlock again...Thank u Dev Team, good job...Now just waiting on the IOS4 jailbreak if it isn't already out!!
    1. AnthonyGiola's Avatar
      AnthonyGiola -
      heya all. I have no idea what exactly Saurik did but DO NOT download those esential updates from cydia. on my 3GS after finishing the download they went into a infinite Reload Springboard. I went ahead and held down lock and power buttons. That put it into a 5:30 minute apple logo then it came back out to the normal screen. Cydia however is more or less inert and will NOT install anything. it gives a POSIX connection refused. this is on wifi and 3G service... Im testing Rock right now. Oh and my theory for why it is messing it up is that he updated so many essential tweaks at once that they have some combined side effect on cydia.

      Rock is confirmed to work. It can still have full functionality. GO ROCK
    1. XFaega's Avatar
      XFaega -
      Quote Originally Posted by jabregousmc View Post
      this is correct. use the beta 5-3 for your iphone 3g or ipt 2g. 3gs still waiting! i'm sure it'll be out pretty quick tho!

      a side question though. has any other 3g owners notice that the official fw runs slower than the GM?? mine seems a lot laggier than the GM i was running before getting the official 4.0. what tha dilly yo??
      Did you restore from back up? Try restore as a new iPhone.
    1. paulvp's Avatar
      paulvp -
      Quote Originally Posted by nickhesson View Post
      [size=1]
      Unlocking iOS 4

      The iPhone Dev Team has released ultrasn0w 0.93 for unlocking your new iOS 4. Simply add the Cydia repo: repo666.ultrasn0w.com. This version of ultrasn0w will unlock basebands 04.26.08 thru 05.13.04. If your unsure, that means that ultrasn0w unlocks ALL basebands since iPhone OS 3.1. Even more specifically, 04.26.08, 05.11.07, 05.15.01, and 05.13.04. Remember to disable 3G on T-Mobile USA.
      I'm assuming that was meant to say 05.12.01?
    1. jabregousmc's Avatar
      jabregousmc -
      Quote Originally Posted by XFaega View Post
      OK Do this -
      1. ( Make sure you backed up and synced all your info ) Go to setting - General - Reset - Erase All Content and Settings
      2. After that you will need iTunes 9.2 and then download iOS4 and install
      3. You will need redsnow .095b5-3 and iOS4 GM
      4. Run redsnow .095b5-3 and point it to iOS4 GM to jailbreak your 3G iPhone
      5. Now update Cydia
      6. Add resource repo666.ultrasn0w.com for Yellowsn0w for unlocking

      That should be it.
      the beta5-3 will jailbreak the OFFICIAL 4.0! just got done jb'ing mine!
    1. Y67H's Avatar
      Y67H -
      Okay. You can jailbreak 4.0 in two different ways, first, if you are running the GM of 4.0, just use redsn0w 9.5. If you have the final version, download redsn0w 9.5 and download the GM version of 4.0. Use that in redsn0w. They are the same build! I have done it twice and let me tell you, multitasking and wallpapers ROCK. the best part, it is an untethered jailbreak too. Have fun jailbreaking.

      PS. Yay! my first post, hopefully there are many more!
    1. mbeezy81's Avatar
      mbeezy81 -
      Might I add the new firmware did run a Little Slower on my 3G. But when I get my IP4 on Thursday shouldn't have that issue with the 512mb of ram lol