• Your favorite

    Apple

    ,

    iPhone

    ,

    iPad

    ,

    iOS

    ,
    Jailbreak
    , and
    Cydia
    site.
  • iTunes 9.2 Released : Not Safe for Spirit Jailbreakers


    While we had been under the impression that iTunes 9.2 would be released alongside iOS 4, it appears that Apple has already pushed the update for iTunes to the public, ahead of the scheduled release with iOS 4 on June 21st, 2010.

    With this update comes some warning notes for the Jailbreak community, as iTunes 9.2 is not fully compatible with the recent Spirit Jailbreak tool. It is currently recommended to stay away from iTunes 9.2 all together unless you have the need to be on iOS 4 GM. If your not familiar with this, then stop what your doing and simply wait this one out.

    If you have not yet jailbroken your device and have iTunes 9.2 installed already, DO NOT ATTEMPT TO JAILBREAK. Your device will go into an infinite boot loop.

    If your iDevice is already jailbroken with Spirit prior to iTunes 9.2, then you shouldn't have any problems, but we still recommend to stay away from this update for now. Comex is aware of this and is looking into the issue further to see if he can't patch things up. Patience my friends.

    IF your using tools other than Spirit, The iPhone Dev Team has confirmed there are no problems with PwnageTool or RedSn0w with the new iTunes 9.2. So those are you best bet for jailbreaking tools if your already on iTunes 9.2 and need to jailbreak.
    This article was originally published in forum thread: iTunes 9.2 Released : Not Safe for Spirit Jailbreakers started by nickhesson View original post
    Comments 140 Comments
    1. tchirou's Avatar
      tchirou -
      5.12.01, just like before. It did not change it.

      It was really quick but I think it looked for activation. As I am unlocked and I still have the good carrier, I do not concentrate on this part.
      Someone else can give you a better answer.
    1. brianlg's Avatar
      brianlg -
      ive been on 9.2 beta, and this doesn't show up in my updates..
    1. Burner911's Avatar
      Burner911 -
      Quote Originally Posted by Antman217 View Post
      I still have the 9.2 beta and that did work with spirit for me. I jailbroke my friends 3GS with spirit and installed 4.0GM on my 3G with 9.2 beta no problem. Btw i did it on a Mac not sure if 9.2 beta is safe for windows though but 9.2 beta does work with spirit... well at least for me it did. I also checked for software update and it did not show up because i guess it reads the beta as a final 9.2 release so if your willing to try, just find a 9.2 beta download and try to use spirit.
      Exactly, to upgrade from 9.2 beta you have to do it manually from the apple site. I'm not really impressed with the speed of my iPhone 3G now though, 4.0 slows it down A LOT

      Quote Originally Posted by brianlg View Post
      ive been on 9.2 beta, and this doesn't show up in my updates..
      iTunes 9.2

      Download 9.2 link from Apple. Enjoy.
    1. I Am Zak's Avatar
      I Am Zak -
      Is there a jailbreak for 4.0 yet?
    1. delizaza23's Avatar
      delizaza23 -
      thank you for the warning.
    1. mOdO's Avatar
      mOdO -
      Quote Originally Posted by I Am Zak View Post
      Is there a jailbreak for 4.0 yet?
      I've just upgraded to 4.0 should have came on here a little quicker!

      Edit: Just read - jailbreak to be released on 21st
    1. brianlg's Avatar
      brianlg -
      Quote Originally Posted by Burner911 View Post
      iTunes 9.2

      Download 9.2 link from Apple. Enjoy.
      Thanks, thats what I just ended up doing. I figured there had to be some kind of difference between the final and the beta.
    1. BenzoHartt's Avatar
      BenzoHartt -
      Good News. Maybe they'll push the official IOS4 release up as well.
    1. DisneyRicky's Avatar
      DisneyRicky -
      It worked for me, Jailbroken iPod Touch and iPad...no problems!

      In My Opinion...Green Light!

    1. drWidowmaker53's Avatar
      drWidowmaker53 -
      Im waiting for someone to give the green light for iPhone 3.1.3 spirit jb.....
    1. MyWI User's Avatar
      MyWI User -
      I got an iPhone 3GS 16gb 3.1.3 jailbroken with Spirit.

      The best bet is to wait, of course, but then what?
    1. drWidowmaker53's Avatar
      drWidowmaker53 -
      Probably wait until the 21st! Ha!
    1. seven77's Avatar
      seven77 -
      Quote Originally Posted by StealthBravo View Post
      Windows users can now install 4.0 GM.
      can i ask what is the ATT_USStealthStock.ipcc file for ? do i need it or not ? THANKS a lot as soon as i get a change i'll donate some mulah m8!
    1. MyWI User's Avatar
      MyWI User -
      So let's assume iOS4 was out now. How would you go about upgrading from 3.1.3 jailbroken with Spirit? Most likely, anyway.

      Would the process be something like restore -> install iOS4 -> jailbreak? Would a restore even be needed at all?
    1. didithu's Avatar
      didithu -
      Windows users can upgrade rite now? With JB tool to keep the old br?
    1. SnowLeo's Avatar
      SnowLeo -
      F*** you apple!!! lol when will they realize that they only create a minor annoyance and temporary setback by doing this crap and end up pissing off their customers. Either way were gonna get a working JB so stop pissing people off you big red fruit!

      if I run spirit on my already Jailbroken 3gs 3.1.3 (w/o 9.2) will it reinstall cydia? because I havent been able to use cydia ever since that last (SH!TTY) update
    1. mikerlx's Avatar
      mikerlx -
      ^just wait
    1. danshop's Avatar
      danshop -
      i just got my ipad and connected it on my laptop and i has itunes 9.2 can i plug it in on my PC sync it with a lower itunes version and jailbreak it?

      thanks in advance
    1. Shishir G's Avatar
      Shishir G -
      Will we be informed here on modmyi forums if updating is safe for spirit jailbreak users?
    1. eortizr's Avatar
      eortizr -
      ok,, so ,, now that 9.2 is on Windows... can I just download a custom 4.0 firmware and loaded to my 3GS that came with 3.1.3?