• Your favorite

    Apple

    ,

    iPhone

    ,

    iPad

    ,

    iOS

    ,
    Jailbreak
    , and
    Cydia
    site.
  • New Features in iPhone Firmware 3.1 beta 3
    Firmware 3.1 beta 3 (build 7C116a ) went live yesterday along with the associated SDK (build 9M2808). These betas available for developers registered in the iPhone Developer Program gives us a good look at what is next in Apple's iPhone firmware.

    3.1 beta 3 allows video to be sent via email.



    Other updates to beta 3 include a baseband update to 5.11.04, various tweaks to APIs, and tethering usage feature added.
    This article was originally published in forum thread: New Features in iPhone Firmware 3.1 beta 3 started by Cody Overcash View original post
    Comments 252 Comments
    1. confucious's Avatar
      confucious -
      What errors are you getting? Lots can just be ignored as they are just telling you that you are trying to install an earlier FW (which can be done) or an earlier BB (which can't).
      Presumably you have tried a DFU restore?
    1. Melech518's Avatar
      Melech518 -
      Yup, I exhausted the options. I dont mind having the phone on the beta, I just cant figure out for the life of me how I downgraded it the first time.

      But this is why I have a tester...so I can do whatever I want to it
    1. confucious's Avatar
      confucious -
      What error's do you get when you try to downgrade? 16xx just means you are downgrading FW and 15xx means you are trying to downgrade the BB both of ehich you should be able to get past - but then, I guess you know what you are doing.

      Like your new sig pic
    1. StealthBravo's Avatar
      StealthBravo -
      Whats going on here?
    1. Melech518's Avatar
      Melech518 -
      I am getting the both the 1605 and the 15whatever errors...cant seem to get past them again. I really want to DG the baseband...Im not sleeping until it is accomplished

      Like your new sig pic
      Thank you sir
    1. StealthBravo's Avatar
      StealthBravo -
      Why dont you just run redsn0w or irecovery following the error? The error just means that itunes hates your baseband mismatch. Run one of those tools to get it out of recovery
    1. Melech518's Avatar
      Melech518 -
      I did that, but I still cant downgrade the BB and thats the main objective right now...
    1. StealthBravo's Avatar
      StealthBravo -
      OH IC

      You can't unless this is a 2G or a 3G with the 5.08 bootloader
    1. Melech518's Avatar
      Melech518 -
      You are going to smack me upside the head if I ask you how to check the bootloader arent you?
    1. StealthBravo's Avatar
      StealthBravo -
      Quote Originally Posted by Melech518 View Post
      You are going to smack me upside the head if I ask you how to check the bootloader arent you?
      yes =P
    1. Melech518's Avatar
      Melech518 -
      haha, I tried using the redsn0w with the 3.0 firmware and I am stuck for 10 minutes on this...
    1. StealthBravo's Avatar
      StealthBravo -
      I thought the baseband was your problem
    1. Melech518's Avatar
      Melech518 -
      oh it is, but then i put the phone back on the beta 3 just to push my luck...I like a challenge
    1. StealthBravo's Avatar
      StealthBravo -
      ^ so you want beta 3 with 3.0 bb ?
    1. dale1v's Avatar
      dale1v -
      Melech it's punishing you for chastising it in the first place.
    1. Melech518's Avatar
      Melech518 -
      I know it is, that whore of a phone and its redsn0w pimp! Stealth I just want 3.0 or 3.0.1 with the 4.26.08 again..thats the main objective
    1. StealthBravo's Avatar
      StealthBravo -
      Quote Originally Posted by Melech518 View Post
      I know it is, that whore of a phone and its redsn0w pimp! Stealth I just want 3.0 or 3.0.1 with the 4.26.08 again..thats the main objective
      lmao

      Well get your phone to phone to 3.0 or 3.01 jailbroken and then we will have to get the fls files to allow you to downgrade the bb
    1. Melech518's Avatar
      Melech518 -
      Gotcha...work in progress again right now...Il let you know when im back there
    1. StealthBravo's Avatar
      StealthBravo -
      ^ Its possible with 5.08 tho
    1. Melech518's Avatar
      Melech518 -
      OKay, its restoring to 3.0.1 right now...