• Your favorite

    Apple

    ,

    iPhone

    ,

    iPad

    ,

    iOS

    ,
    Jailbreak
    , and
    Cydia
    site.
  • ultrasn0w is out - 3.0 Unlocked!


    The DevTeam has released ultrasn0w! Unlocking your 3.0 iPhone or iPhone 3G is super easy now - just turn off 3G, open up Cydia, add their repo, and install ultrasn0w. Done!

    For all who are going to ask - NO THIS DOES NOT WORK ON THE IPHONE 3GS, SINCE THE IPHONE 3GS IS NOT JAILBROKEN YET. WHEN THAT HAPPENS WE'LL LET YOU KNOW.
    1. Please add the repo repo666.ultrasn0w.com to cydia or icy
    2. Search for ‘ultrasn0w’ in cydia or icy and install ultrasn0w
    3. Reboot your iPhone 3G
    4. T-Mobile USA users should disable 3G before using ultrasn0w
    5. Enjoy





    DevTeam blog
    This article was originally published in forum thread: ultrasn0w is out - 3.0 Unlocked! started by Kyle Matthews View original post
    Comments 411 Comments
    1. Empyrials's Avatar
      Empyrials -
      Quote Originally Posted by Turb02 View Post
      How did you get MMS to work? Ive followed the "MMS" thread to a "T" and still cant send a MMS. It just hangs up at about 90% then fails.
      i had problems at first too(my settings below), i'm not sure why i did but in the process i also went to enable tethering through safari. after i downloaded that i re-changed my settings and i was able to send MMS messages. I was able to recieve MMS fine just couldn't send until i enabled tethering.

      I really doubt it had anything to do with the tethering file it downloads just saying it's how mine worked.. dunno.



      also before i enabled tethering i noticed my apn's disappeared for some reason after i put them in, so i guess just double check your settings and hopefully it works.


      here's my settings:
      - Cellular Data APN: internet2.voicestream.com
      - MMS
      APN: wap.voicestream.com
      MMSC: 216.155.174.84/servlets/mms
      MMS Proxy: 215.155.165.50:8080
      Leave Username/Password/MMS Size/MMS UA blank


      EDIT: oh ya don't forget to reboot after you set your settings
    1. Freshumz's Avatar
      Freshumz -
      I just unlocked my iphone 3g and it works perfectly fine right now. Im on wifi and am not using Edge or tethering as of yet. Text messages work as well as calls. For those that still have problems Jailbreaking and Unlocking, I thought Id tell you EXACTLY what I did instead of just saying my iphone works like some people and leave it at that(no offense) haha =P

      Btw....THANK YOU DEV TEAM, MODMYI.COM, AND ALL OF YOU FOR THE GREAT ADVICE

      *ahem* now then:

      1. I upgraded my iphone through itunes with my tmobile sim still installed.
      2. Leave the Iphone connected after the upgrade
      3. Run Redsn0w WITH TMOBILE SIM STILL INSTALLED (Im on a mac btw)
      4. Locate the 3.0 update file located in the itunes folder of your computer
      5. Follow Redsn0w instructions precisely. (It goes pretty fast so be cautious as soon as u click next after connecting and turning off your phone)
      6. Your Iphone should be activated.
      7. Go to Cydia and go to your sources section under "Manage" i believe
      8. Type in the repe site for "Ultrasn0w"
      9. Install it (WITH TMOBILE SIM STILL INSTALLED)
      10. Reboot your phone

      SHAMWOW!!!! YOUR IPHONE IS NOW STYLIN

      For those that need visual I found this in someones comment:

      JailBreak (Windows):

      [ame=http://www.youtube.com/watch?v=6YyHPxl4NwU&feature=playe]YouTube - Jailbreak 3.0 Firmware iPhone or iPod Touch[/ame]


      Unlock:

      [ame=http://www.youtube.com/watch?v=AxML7FkwfgE&feature=player_embedded]YouTube - How To Unlock Your iPhone 3G On NEW 3.0 Firmware With Ultrasnow[/ame]

      Goodluck!!
    1. redzombi2k's Avatar
      redzombi2k -
      Ahh! Well I keep getting this error when trying to install Ultrsn0w.
      I think it is doing all the upgrades and then Ultrasn0w at the end, any ideas?

      Is there maybe a manual way to install Ultrasn0w?
      Also, I cant even find ultrsn0w in icy. Did something go wrong with the jailbreak u think?
      Im, totally dumfounded..
    1. Turb02's Avatar
      Turb02 -
      Quote Originally Posted by Empyrials View Post
      i had problems at first too(my settings below), i'm not sure why i did but in the process i also went to enable tethering through safari. after i downloaded that i re-changed my settings and i was able to send MMS messages. I was able to recieve MMS fine just couldn't send until i enabled tethering.

      I really doubt it had anything to do with the tethering file it downloads just saying it's how mine worked.. dunno.



      also before i enabled tethering i noticed my apn's disappeared for some reason after i put them in, so i guess just double check your settings and hopefully it works.


      here's my settings:
      - Cellular Data APN: internet2.voicestream.com
      - MMS
      APN: wap.voicestream.com
      MMSC: 216.155.174.84/servlets/mms
      MMS Proxy: 215.155.165.50:8080
      Leave Username/Password/MMS Size/MMS UA blank


      EDIT: oh ya don't forget to reboot after you set your settings
      I guess Ishould have stated that Im on AT&T running 3.0 JB and unlocked. For some reason I called ATT cust support and they changed my plan for a "different phone", sent a few MMS, and made sure I could call and hit the www, then swapped my SIM back to the iPhone, still nothing...

      Im on hold with cust support because I swapped my sim back ofer to my old BB and MMS didnt work...they said that switching back and forth screws with the back end of the system and I have to choose between one phone or the other. THIS BLOWS!!!
    1. khaoticsquirrel's Avatar
      khaoticsquirrel -
      i don't wanna sound stupid by asking this, but does this unlock the edge phones as well?

      i jailbroke mine already, and i didn't want to upgrade my girlfriend's phone yet until i knew i could unlock it..
    1. confucious's Avatar
      confucious -
      UltraSn0w is for the 3G. The original iPhone can be unlocked with RedSn0w.
    1. iPwneDmIiPhone's Avatar
      iPwneDmIiPhone -
      Quote Originally Posted by Melech518 View Post
      Anyone else notice that a lot of themes do not work the same on 3.0. Such as, SMSBackground, Tmobile logo, keyboards....just to name a few things i notice so far. Did apple change the names and locations of where these files are located?
      its because some things such as the texting are named differently, on the 2.2.1 fw texting was called "text" on the 3.0 fw its called "messages" all you need to do to fix such things is SSH into iphone and rename your .png files
    1. stehlin14's Avatar
      stehlin14 -
      I upgraded then jailbroke then used ultrasn0w to unlock but i cannot get service! does anyone have this problem? does anyone kno of ways to get service or something critical i should have done?
      please help.
    1. Zameus's Avatar
      Zameus -
      Quote Originally Posted by confucious View Post
      When blkardi sait 3G does not work on T-Mobile she was, of course, only refering to the USA - it works fine in every other country.

      But, to answer your question, with 3G turned on it will try and connect to T's 3G network and fail so you won't get a signal. If you turn 3G off again it will only look for their GSM network and you will be OK. You won't brick your phone.
      I'm in the US.

      Thanks for clearing that up for me Confucious!
    1. wbennin20's Avatar
      wbennin20 -
      Thanks to all the guys that put in some hard work for the unlock on the 3g.

      I have a slight problem with my 3g on Tmobile, after my unlock following all the steps 3g disabled and what no; I came across this problem. the phone works fine after the reboot. speaker is loud and clear. then the sits for some time when I then take it and slide to unlock the speaker is very low, I check the volume it fine, I initially ignored it and tried to make a call and I couldn't so I tried going into voicemail and the timer started as if I was on the call but nothing. I reboot the phone and its all good. this has been happening all day. anyone else notice this
    1. rowong's Avatar
      rowong -
      Hello all,

      I just have two questions before I go ahead and upgrade to 3.0 and unlock my iPhone 3G.

      1) Is it a MUST to upgrade itunes to version 8.2 before I upgrade to 3.0?

      2) Do I need to upgrade to 3.0 via itune's upgrade button, or can I download the 3.0 firmware and click Restore while pressing Shift to restore to the 3.0 firmware ?

      Any help is much appreciated

      Thanks!
    1. cdouglas's Avatar
      cdouglas -
      Hey Guys i did everything and it worked fine i have one problem doh sometimes after i finish a call i get a message on my phone saying it has gone into safe mode because springboard has crashed is there a fix for this problem or does anyone else experience this

      i have a 8gb iphone 2g running 3.0 and 16gb iphone 3g running 3.0 and the problem happens with both phones
      im using windows vista 32bit

      someone please help its a really irritating problem

      thanks
    1. xrated's Avatar
      xrated -
      is there a way to get rid of that search option thingy on the main screen.. hate this thing no used for it.
    1. confucious's Avatar
      confucious -
      Quote Originally Posted by rowong View Post
      Hello all,

      I just have two questions before I go ahead and upgrade to 3.0 and unlock my iPhone 3G.

      1) Is it a MUST to upgrade itunes to version 8.2 before I upgrade to 3.0?

      2) Do I need to upgrade to 3.0 via itune's upgrade button, or can I download the 3.0 firmware and click Restore while pressing Shift to restore to the 3.0 firmware ?

      Any help is much appreciated

      Thanks!
      1) Yes
      2) Just restore (not shift restore) in iTunes - it will download and install a clean version of FW3.0
    1. justin7942163's Avatar
      justin7942163 -
      Quote Originally Posted by rowong View Post
      Hello all,

      I just have two questions before I go ahead and upgrade to 3.0 and unlock my iPhone 3G.

      1) Is it a MUST to upgrade itunes to version 8.2 before I upgrade to 3.0?

      2) Do I need to upgrade to 3.0 via itune's upgrade button, or can I download the 3.0 firmware and click Restore while pressing Shift to restore to the 3.0 firmware ?

      Any help is much appreciated

      Thanks!
      1.) YES

      2.) You can do either, but I recommend updating it to 3.0 through iTunes, thats what I did and everything works fine. It's all Up to you though.
    1. confucious's Avatar
      confucious -
      Quote Originally Posted by justin7942163 View Post
      1.) YES

      2.) You can do either, but I recommend updating it to 3.0 through iTunes, thats what I did and everything works fine. It's all Up to you though.
      I really recommend restoring in iTunes NOT upgrading.
    1. justin7942163's Avatar
      justin7942163 -
      Quote Originally Posted by cdouglas View Post
      Hey Guys i did everything and it worked fine i have one problem doh sometimes after i finish a call i get a message on my phone saying it has gone into safe mode because springboard has crashed is there a fix for this problem or does anyone else experience this

      i have a 8gb iphone 2g running 3.0 and 16gb iphone 3g running 3.0 and the problem happens with both phones
      im using windows vista 32bit

      someone please help its a really irritating problem

      thanks
      Do as confucious says!
    1. confucious's Avatar
      confucious -
      Quote Originally Posted by xrated View Post
      is there a way to get rid of that search option thingy on the main screen.. hate this thing no used for it.
      It's to the left of the main screen - if you don't like it then ignore it, you can't get rid of it.
      most people find it very useful!
    1. Freshumz's Avatar
      Freshumz -
      Quote Originally Posted by Empyrials View Post
      i had problems at first too(my settings below), i'm not sure why i did but in the process i also went to enable tethering through safari. after i downloaded that i re-changed my settings and i was able to send MMS messages. I was able to recieve MMS fine just couldn't send until i enabled tethering.

      I really doubt it had anything to do with the tethering file it downloads just saying it's how mine worked.. dunno.



      also before i enabled tethering i noticed my apn's disappeared for some reason after i put them in, so i guess just double check your settings and hopefully it works.


      here's my settings:
      - Cellular Data APN: internet2.voicestream.com
      - MMS
      APN: wap.voicestream.com
      MMSC: 216.155.174.84/servlets/mms
      MMS Proxy: 215.155.165.50:8080
      Leave Username/Password/MMS Size/MMS UA blank


      EDIT: oh ya don't forget to reboot after you set your settings

      Where do you find the instructions on activating MMS? Because currently I do not have the MMS button on my iphone and do not know how to get it. I notice there is settings in Network for it, but not sure if I should input the data above..and yes I downloaded the tethering anad enabled it. Any help is good help
    1. confucious's Avatar
      confucious -
      Just input the settings and reboot.