• Your favorite

    Apple

    ,

    iPhone

    ,

    iPad

    ,

    iOS

    ,
    Jailbreak
    , and
    Cydia
    site.
  • TinyUmbrella Updated - Save Your SHSH Files!
    With the new iOS 4.1 update around the corner, it is more important than ever to back up your SHSH files to ensure that you will be able to downgrade to 4.0 after the new update has been released.

    TinyUmbrella, a handy application which allows you to both save your SHSH files and also use them to downgrade, isn't new - but it has been updated with performance improvements and a nice big GUI upgrade. More information on the improvements and the new features can be found at the developers blog, here. With 4.1 right around the corner, we figured now's a good time to remind everyone.



    A recent tweet from @planetbeing stresses the importance to back up your SHSH Blobs before updating to the new 4.1 firmware.



    Saving your SHSH Blobs using TinyUmbrella is very easy, and takes hardly any time at all. One of the advantages of using TinyUmbrella to save your SHSH is that it bypasses the need for a jailbroken device. Also, when downgrading a device, TinyUmbrella sets up its own virtual server on your machine, and tells iTunes to connect to it via your hosts file. All this is automated and separate from the Cydia server, making it a lot simpler to downgrade. Because your SHSH files are saved locally, you may also back them up yourself, as oppose to them being stored on a server somewhere where you can't access them.

    TinyUmbrella can be downloaded from here.
    This article was originally published in forum thread: TinyUmbrella Updated - Save Your SHSH Files! started by Owen Priestley View original post
    Comments 272 Comments
    1. peoples_flip's Avatar
      peoples_flip -
      Quote Originally Posted by exNavy View Post
      You don't have to upgrade to 4 to save the blobs for 4.
      But it when I ran TinyUmbrella it was saving my 3.1.3 blobs... how do I have 4.0 without installing it?

      NVM found it... thanks for the advice.
    1. moudy's Avatar
      moudy -
      Quote Originally Posted by peoples_flip View Post
      But it when I ran TinyUmbrella it was saving my 3.1.3 blobs... how do I have 4.0 without installing it?

      NVM found it... thanks for the advice.
      Go advanced and select the 4.0 SHSH and save them.
      I have the 4.0 saved for both my 3GSs one is on 3.1.2 and the other on 3.1.3.
    1. ipod touch u's Avatar
      ipod touch u -
      im getting a java start-up error when i try to open the file after i download it, anyone have any idea how to fix this? im using windows.
    1. iphonerookie's Avatar
      iphonerookie -
      need to install java on your pc^
    1. gmoore's Avatar
      gmoore -
      Quote Originally Posted by blast123 View Post
      y cant my mac ever open this software??
      Copy to application folder then open. Didn't work for me opening off the disc image.
    1. zozodouce's Avatar
      zozodouce -
      ok cydia got my goods lol
    1. wolverinemarky's Avatar
      wolverinemarky -
      what device do i choose for my iphone 3G, are the 3gs choices ok to use for the 3G?
    1. zozodouce's Avatar
      zozodouce -
      [QUOTE=wolverinemarky;5344775]what device do i choose for my iphone 3G, are the 3gs choices ok to use for the 3G?

      dude you should give that 3g to a kid to play with lol, dont mean to make fun of you hahahahaha.
    1. wolverinemarky's Avatar
      wolverinemarky -
      [quote=zozodouce;5344776]
      Quote Originally Posted by wolverinemarky View Post
      what device do i choose for my iphone 3G, are the 3gs choices ok to use for the 3G?

      dude you should give that 3g to a kid to play with lol, dont mean to make fun of you hahahahaha.
      lol i will once the white iphone 4s are released. ive been waiting a while so till then i need my toy of a 3G lol so which one do i use
    1. UTPharmer's Avatar
      UTPharmer -
      Quote Originally Posted by ipod touch u View Post
      im getting a java start-up error when i try to open the file after i download it, anyone have any idea how to fix this? im using windows.
      WAIT until the file finishes downloading...Dumbass

      (I did the same thing, but I didn't ask a stupid question on a forum. You've been called out.)
    1. zozodouce's Avatar
      zozodouce -
      [quote=wolverinemarky;5344779]
      Quote Originally Posted by zozodouce View Post

      lol i will once the white iphone 4s are released. ive been waiting a while so till then i need my toy of a 3G lol so which one do i use
      clik on advanced options from there you can pick your device lol. oh sory you dont need that for 3g.
    1. EddieLeonard's Avatar
      EddieLeonard -
      done it
    1. Dj Meltdown's Avatar
      Dj Meltdown -
      Hey guys, this is the first time I've used TU. I'm on win7 64bit, I run the program as an administrator , when it tries to connect the program tells me it's no being run as an administrator. The it proceeds to work anyway. I have 3.1.2 and 3.1.3 on cydia, do the both save in the same shsh file or should the be a file for each? Even thought the process completed, has it done it properly considering the admin error?
      Would it be better to run in xp service pack 3 mode?
    1. skater38053's Avatar
      skater38053 -
      Quote Originally Posted by delusion950 View Post
      I think new umbrella supports ipad 3gs and iphone 4g ipod 2G and ipod touch 3g. Correct me if am wrong but i just checked umbrella




      Yes Cydia is location

      Can I save two different phones on one computer?
    1. liamwalsh21's Avatar
      liamwalsh21 -
      On the tweet it says to save 4.0 SHSH regardless of what firmware your on and what jailbreak status. How can i save 4.0 blobs if im on 3.1.3? Upgrade to 4.0 save them and downgrade again?
    1. maxgsteinberg's Avatar
      maxgsteinberg -
      If I haven't upgraded my 3Gs 3.1.3 to 4.0 software should I do it? Will I be able to save my shsh blobs for 4.0 without upgrading? Greatly appreciate any help
    1. iLaw-One's Avatar
      iLaw-One -
      Quote Originally Posted by maxgsteinberg View Post
      If I haven't upgraded my 3Gs 3.1.3 to 4.0 software should I do it? Will I be able to save my shsh blobs for 4.0 without upgrading? Greatly appreciate any help
      I presume you already have 3.1.3 stored...if so, upgrade to 4.0, save the SHSH, then JB using pwnage or redsnow. You can't have SHSH saved for any firmware if your device isn't running that firmware prior to your attempt to save it....hope this helps.

      Quote Originally Posted by skater38053 View Post
      Can I save two different phones on one computer?
      I believe you can, as the SHSH for each device is different...eg the SHSH for your 3GS is different to your iPhone 4....Tiny Umbrella will tell you what device you have connected and what version firmware you are running on that device.
    1. exNavy's Avatar
      exNavy -
      Quote Originally Posted by maxgsteinberg View Post
      If I haven't upgraded my 3Gs 3.1.3 to 4.0 software should I do it? Will I be able to save my shsh blobs for 4.0 without upgrading? Greatly appreciate any help
      If you read the earlier posts, you'd see you do NOT need to be on 4.0 to save an ecid shsh for 4.0.

      The post immediately after your original post is wrong. If you want to stay on 3.1.3 you can. You'll still be able to use Cydia or Tiny to get the newer firmware signature.

      When Apple stops signing 4.0 that is when you will have a problem. Example: you can't get an ecid shsh for 3.1.3 any more, because they aren't signing it any more.
    1. liamwalsh21's Avatar
      liamwalsh21 -
      Is it simple enough to do once i download tinyumbrella or is there a guide anywhere?
    1. iLaw-One's Avatar
      iLaw-One -
      Quote Originally Posted by Dj Meltdown View Post
      Hey guys, this is the first time I've used TU. I'm on win7 64bit, I run the program as an administrator , when it tries to connect the program tells me it's no being run as an administrator. The it proceeds to work anyway. I have 3.1.2 and 3.1.3 on cydia, do the both save in the same shsh file or should the be a file for each? Even thought the process completed, has it done it properly considering the admin error?
      Would it be better to run in xp service pack 3 mode?

      I did mine on the mac and didn't get a chance to see the windows version before leaving for work this morning...but on the mac version of Tiny Umbrella, there's a message to tell you it's been successful, and a link to allow you view the location of where it's stored. I believe the windows version won't be any different considering that was one of the reasons TU was updated.

      Once you can verify the above (message and link) you are ok. Hope that helps.

      Quote Originally Posted by exNavy View Post
      If you read the earlier posts, you'd see you do NOT need to be on 4.0 to save an ecid shsh for 4.0.

      The post immediately after your original post is wrong. If you want to stay on 3.1.3 you can. You'll still be able to use Cydia or Tiny to get the newer firmware signature.

      When Apple stops signing 4.0 that is when you will have a problem. Example: you can't get an ecid shsh for 3.1.3 any more, because they aren't signing it any more.

      I think you may have misunderstood his question...if he NEVER intends to upgrade his device to any firmware other than the one he is currently on ( which I believe is below 3.1.3), then he would be ok...

      I however think that eventually, we would all be forced to upgrade at some point if we want to use newer apps (not necessarily updates), and Apple WILL eventually stop signing 4.0 (they've done similar in the past and only to deter JB'ing).

      Educate me if I'm wrong, but how can you save an SHSH for a firmware that you don't even have? TU identifies the firmware on your device when you connect it, and allows you to back up THAT firmware.
      I didn't realise it could generate a non-existent SHSH for the device *confused*
      It's like using Photoshop cs4 and wanting to save a file you're editing as a cs5 version...