• Your favorite

    Apple

    ,

    iPhone

    ,

    iPad

    ,

    iOS

    ,
    Jailbreak
    , and
    Cydia
    site.
  • PwnageTool 4.0 Released: Jailbreak & Unlock iOS 4


    Update: For anyone who saw iBooks problems after redsn0w beta, try the latest one (see update #2 at Dev-Team Blog - all four one! )

    Just one day after the relase of iOS 4.0, the Dev-Team has done it once again. Not only did they release an unlock tool the day iOS 4 came out, they have now released a brand new version of PwnageTool for creating custom iOS 4.0 firmware packages. This means almost everyone can get on board now. *almost everybody.

    As per usual, the same instructions apply that have always been the case with PwnageTool. Follow the onscreen instructions just as they say. Within a few minutes you will have a custom firmware package to install. But don't get too far ahead of yourself. You need to scroll down and read the instructions provided by the Dev-Team.

    If you have been tinkering with the unofficial release of PwnageTool 4.0, we strongly urge you to restore and use this version instead as the leaked version did not include patches that are required for ultrasn0w unlock.

    Download PwnageTool 4.01 for Mac:
    MMi Member Mirror
    Rapidshare
    Megaupload

    Download PwnageTool 4.0 for Mac:
    MMi Member Mirror
    Rapidshare
    Megaupload
    Mediafire

    *PLEASE READ THE FOLLOWING VERY CAREFULLY!

    Dev-Team Blog

    As advised, you shouldn’t have upgraded your devices if you have previously relied on our tools for hacktivation and/or a carrier unlock.

    Each supported device has few different scenarios that users need to consider when performing the upgrades, you need to check below and perform the upgrade in the particular way that matches your current device state.

    NB: With PwnageTool 4.0 certain devices are not supported this is because they are not supported in iOS 4.0 or they are not supported by our software.

    iPhone 2G - not supported
    iPod Touch - not supported
    iPod Touch 3G - not supported
    iPhone 3G

    If you have a Jailbroken iPhone 3G at 3.1.2 (but not jailbroken with Spirit) then you should create the ipsw with PwnageTool 4.0 and restore from recovery mode or DFU mode.
    If you have an out of the box iPhone 3G you should restore using a PwnageTool 4.0 ipsw using DFU mode.
    If you have a Jailbroken 3.1.3 iPhone 3G it is very possible that this can fail from recovery mode, if this failure happens you will need to restore using DFU mode.
    IMPORTANT! Whenever you need to enter DFU mode, you will need to do so using PwnageTool.

    iPhone 3GS

    Summary: PwnageTool only works on previously jailbroken 3GS devices with the old bootrom.

    If you have a Jailbroken iPhone 3GS with the OLD BOOTROM and you DID NOT use Spirit to jailbreak then you can create the ipsw with PwnageTool 4.0 and restore with recovery mode.
    If you have an iPhone 3GS with the NEW BOOTROM this is NOT supported by PwnageTool 4.0
    iPod touch 2G

    If you have an iPod touch 2G that is jailbroken (but not with Spirit) then you can restore using recovery mode.
    Baseband Unlock

    iPhone 3G and 3GS baseband unlockers (those who rely on ultrasn0w to make phone calls) should always be very wary to update their firmware, however our Ultrasn0w application will unlock all recent (including the current) 3GS and 3G baseband firmware versions, once you are jailbroken using PwnageTool 4.0, install ultrasn0w from Cydia and you’ll be unlocked.

    Remember! This baseband unlock situation is rare, should you upgrade your iPhone blindly at the next iOS release please don’t expect an unlock - but for now you are OK (whatever state your baseband is in).
    This article was originally published in forum thread: PwnageTool 4.0 Released: Jailbreak & Unlock iOS 4 started by nickhesson View original post
    Comments 616 Comments
    1. Cer0's Avatar
      Cer0 -
      Try with it in regular mode. Like have on the regular iPhone screen.
    1. jahitian's Avatar
      jahitian -
      Quote Originally Posted by jahitian View Post
      Hi guys,

      I had jailbroken my iphone 3GS with pwnage tool 4.0 (old bootrom, worked great) and was pissed off as ibooks did not work, all the rest worked fine though.

      So I wanted to jailbreak it again with pwnage tool 4.01 and I am stuck... the recovery hangs towards the end of the recovery status bar in iTunes and on my iPhone.

      I've tried to restore it twice, in recovery mode and once in DFU mode (got an error 1600).

      I do no know what to do anymore to get my iPhone working again, could someone please help me?

      EDIT:


      I followed one1's tutorial and got stuck again midway through restore,i googled and found a little handy trick that saved my day.

      Restored in DFU mode to 3.1.2, then when i got blocked half-way through restore, I launched blackra1n, magic trick, the restore resumed and I was able to get back to 3.1.2, jailbroke with blackr1n then successfully restored to my pwnd's custom firmware.

      A big thank you to one1 and google.
    1. hank197857's Avatar
      hank197857 -
      Quote Originally Posted by jahitian View Post
      Hi guys,

      I had jailbroken my iphone 3GS with pwnage tool 4.0 (old bootrom, worked great) and was pissed off as ibooks did not work, all the rest worked fine though.

      So I wanted to jailbreak it again with pwnage tool 4.01 and I am stuck... the recovery hangs towards the end of the recovery status bar in iTunes and on my iPhone.

      I've tried to restore it twice, in recovery mode and once in DFU mode (got an error 1600).

      I do no know what to do anymore to get my iPhone working again, could someone please help me?
      try using spirit then blackra1n to get you back to where you started from - everything but ibooks.
    1. lewisdenny's Avatar
      lewisdenny -
      Im looking forward to when the ipod touch 3rd gn is4 is jailbroken i miss my jailbreak apps.
    1. bluemage08's Avatar
      bluemage08 -
      guys pwnagetool 4.0 for windows?? when you gonna have it?

      have this problem with my iphone 3gs,bb5.12,bl6.4 mcmodel. i dont know what to do with this. i already restore it to 3.1.3 firmware, i used snowbreeze but i get an error when i make the restore with the custom ipsw. i need help pls... mail me [email protected]

      i really appreciate everyones help. i havnt used my iphone for morethan 3 months already... i still hope that theres still a remedy on my problem.

      God bless!!!
    1. sunny416's Avatar
      sunny416 -
      works perfectly. got it in the first try.
    1. talbott's Avatar
      talbott -
      doesn't work on new bootrom...
    1. confucious's Avatar
      confucious -
      Quote Originally Posted by bluemage08 View Post
      guys pwnagetool 4.0 for windows?? when you gonna have it?

      have this problem with my iphone 3gs,bb5.12,bl6.4 mcmodel. i dont know what to do with this. i already restore it to 3.1.3 firmware, i used snowbreeze but i get an error when i make the restore with the custom ipsw. i need help pls... mail me [email protected]

      i really appreciate everyones help. i havnt used my iphone for morethan 3 months already... i still hope that theres still a remedy on my problem.

      God bless!!!
      Why try Sn0wbreeze? Do you want to trash your phone?
      If you can restore to 3.13 why not use Spirit then UltraSn0w? What's the problem?
    1. bluemage08's Avatar
      bluemage08 -
      @confucious, i already tried spirit.compatibility mode, but then it asked me to have itunes 9, but i was already running in itunes 9.1. i dont want to trash my phone, thats why almost everyday,im on the net waiting and asking for some brand new ideas. i dont care if i look like a fool. but i just want to ask. instead of having it fix and pay very expensive, i will juts try to fix it myself, by everyones help here..thanks anyways. if u have any idea. maybe you can help me out.
    1. drmias's Avatar
      drmias -
      Quote Originally Posted by bluemage08 View Post
      @confucious, i already tried spirit.compatibility mode, but then it asked me to have itunes 9, but i was already running in itunes 9.1. i dont want to trash my phone, thats why almost everyday,im on the net waiting and asking for some brand new ideas. i dont care if i look like a fool. but i just want to ask. instead of having it fix and pay very expensive, i will juts try to fix it myself, by everyones help here..thanks anyways. if u have any idea. maybe you can help me out.
      If you're on 3.1.3, the best\Easiest method you'll ever find is to use Spirit, and then UltraSn0w, you only have to have an Original Carrier Sim in order to activate it, if you're already activated, then you're ok to go.
    1. bluemage08's Avatar
      bluemage08 -
      i try to checkon iforcast, it says that i can only jailbreak it if i save shsh file.but how can i do it my phone is stuck to emergency call. . where to save the shsh file in order for me to JB the device,iphone 3gs,fw 3.1.3 bb 5.12.01 bl 6.4 mc model.
    1. drmias's Avatar
      drmias -
      Quote Originally Posted by bluemage08 View Post
      i try to checkon iforcast, it says that i can only jailbreak it if i save shsh file.but how can i do it my phone is stuck to emergency call. . where to save the shsh file in order for me to JB the device,iphone 3gs,fw 3.1.3 bb 5.12.01 bl 6.4 mc model.
      You need an original carrier Sim. Probably AT&T.. get one from a friend or eBay.
    1. bluemage08's Avatar
      bluemage08 -
      i dont have original carrear, i bought this phone in spain.now im back in phils. so i dont have the spain sim card. but everytime i use spirit, it always ask me to have itunes 9.1 but im already running itunes 9.1..already even tried compatibility mode.. but still.. thanks anyways..
    1. confucious's Avatar
      confucious -
      So why can't you just use Spirit on 3.13?
    1. bluemage08's Avatar
      bluemage08 -
      i got this error:

      INFO: Now listening for devices...

      INFO: read igor/map.plist

      INFO: Connected to the AppleMobileDevice.

      INFO: Version iPhone2,1_3.1.3

      INFO: Connecting to mobilebackup...

      INFO: Sending files via AFC.

      FATAL(__LINE__): Assertion failed (dl.c:198): 0 == (AMDeviceStartService(dev, service, &it, NULL)) (but it was -402653091)

      198

      how to fix?? switch to compatability mode?? still doesnt work.cause it ask me to have itunes 9.1 or higher, im already running to it.
    1. drmias's Avatar
      drmias -
      Quote Originally Posted by bluemage08 View Post
      i got this error:

      INFO: Now listening for devices...

      INFO: read igor/map.plist

      INFO: Connected to the AppleMobileDevice.

      INFO: Version iPhone2,1_3.1.3

      INFO: Connecting to mobilebackup...

      INFO: Sending files via AFC.

      FATAL(__LINE__): Assertion failed (dl.c:198): 0 == (AMDeviceStartService(dev, service, &it, NULL)) (but it was -402653091)

      198

      how to fix?? switch to compatability mode?? still doesnt work.cause it ask me to have itunes 9.1 or higher, im already running to it.
      You MUST Have had your device activated first in order to use Spirit.
    1. bluemage08's Avatar
      bluemage08 -
      @demias, yeah, but i dont have the original sim. and i bought this phone from spain. now im athome Philippines..and i dont have a simcard from spain.. thanks guys.. i dont really know what to do with my phone.
    1. confucious's Avatar
      confucious -
      Get a SIM from Spain.
    1. bluemage08's Avatar
      bluemage08 -
      cause i can restore it to original apple 3.1.3, but like for example.i will use the custom ipsw. from snowbreeze, it always shows error


      thanks for your kind ideas, and for your time,answering my questions!
    1. drmias's Avatar
      drmias -
      Quote Originally Posted by bluemage08 View Post
      cause i can restore it to original apple 3.1.3, but like for example.i will use the custom ipsw. from snowbreeze, it always shows error


      thanks for your kind ideas, and for your time,answering my questions!
      ONLY If you have your device currently JailBroken, you can use a custom firmware.