• Your favorite

    Apple

    ,

    iPhone

    ,

    iPad

    ,

    iOS

    ,
    Jailbreak
    , and
    Cydia
    site.
  • PwnageTool 4.0 Released: Jailbreak & Unlock iOS 4


    Update: For anyone who saw iBooks problems after redsn0w beta, try the latest one (see update #2 at Dev-Team Blog - all four one! )

    Just one day after the relase of iOS 4.0, the Dev-Team has done it once again. Not only did they release an unlock tool the day iOS 4 came out, they have now released a brand new version of PwnageTool for creating custom iOS 4.0 firmware packages. This means almost everyone can get on board now. *almost everybody.

    As per usual, the same instructions apply that have always been the case with PwnageTool. Follow the onscreen instructions just as they say. Within a few minutes you will have a custom firmware package to install. But don't get too far ahead of yourself. You need to scroll down and read the instructions provided by the Dev-Team.

    If you have been tinkering with the unofficial release of PwnageTool 4.0, we strongly urge you to restore and use this version instead as the leaked version did not include patches that are required for ultrasn0w unlock.

    Download PwnageTool 4.01 for Mac:
    MMi Member Mirror
    Rapidshare
    Megaupload

    Download PwnageTool 4.0 for Mac:
    MMi Member Mirror
    Rapidshare
    Megaupload
    Mediafire

    *PLEASE READ THE FOLLOWING VERY CAREFULLY!

    Dev-Team Blog

    As advised, you shouldn’t have upgraded your devices if you have previously relied on our tools for hacktivation and/or a carrier unlock.

    Each supported device has few different scenarios that users need to consider when performing the upgrades, you need to check below and perform the upgrade in the particular way that matches your current device state.

    NB: With PwnageTool 4.0 certain devices are not supported this is because they are not supported in iOS 4.0 or they are not supported by our software.

    iPhone 2G - not supported
    iPod Touch - not supported
    iPod Touch 3G - not supported
    iPhone 3G

    If you have a Jailbroken iPhone 3G at 3.1.2 (but not jailbroken with Spirit) then you should create the ipsw with PwnageTool 4.0 and restore from recovery mode or DFU mode.
    If you have an out of the box iPhone 3G you should restore using a PwnageTool 4.0 ipsw using DFU mode.
    If you have a Jailbroken 3.1.3 iPhone 3G it is very possible that this can fail from recovery mode, if this failure happens you will need to restore using DFU mode.
    IMPORTANT! Whenever you need to enter DFU mode, you will need to do so using PwnageTool.

    iPhone 3GS

    Summary: PwnageTool only works on previously jailbroken 3GS devices with the old bootrom.

    If you have a Jailbroken iPhone 3GS with the OLD BOOTROM and you DID NOT use Spirit to jailbreak then you can create the ipsw with PwnageTool 4.0 and restore with recovery mode.
    If you have an iPhone 3GS with the NEW BOOTROM this is NOT supported by PwnageTool 4.0
    iPod touch 2G

    If you have an iPod touch 2G that is jailbroken (but not with Spirit) then you can restore using recovery mode.
    Baseband Unlock

    iPhone 3G and 3GS baseband unlockers (those who rely on ultrasn0w to make phone calls) should always be very wary to update their firmware, however our Ultrasn0w application will unlock all recent (including the current) 3GS and 3G baseband firmware versions, once you are jailbroken using PwnageTool 4.0, install ultrasn0w from Cydia and you’ll be unlocked.

    Remember! This baseband unlock situation is rare, should you upgrade your iPhone blindly at the next iOS release please don’t expect an unlock - but for now you are OK (whatever state your baseband is in).
    This article was originally published in forum thread: PwnageTool 4.0 Released: Jailbreak & Unlock iOS 4 started by nickhesson View original post
    Comments 616 Comments
    1. KartRacer's Avatar
      KartRacer -
      I have two 3GS's with the new bootrom that I'm going to give to my parents. Do I have to unlock them for them to use them? They are out of contract on AT&T and I don't want to put them in jeopardy of AT&T forcing them to change plans. My Mom has an unlocked 3G, my old one, and she hasnt had any contact about having one from AT&T. They don't care about having data and I don't want to cause them to have to upgrade plans. Does anyone know?

      I know the jailbreak isn't out for the new bootrom 3GSs, but since this deals with unlocks I thought I'd ask.
    1. Azulfuego's Avatar
      Azulfuego -
      What methods other than vmware (which doesnt work for me on win 7) are people using to run a virtual mac OS on a PC for things like this?
      Thanks
    1. mrdjflood's Avatar
      mrdjflood -
      Quote Originally Posted by confucious View Post
      You can not go to 4 and JB
      3GS iBoot-359.3 Upgraded to 4.0, first jailbreak blackra1n, SHSH onfile (Cydia) 3.1.3 jailbreak with spirit, can i ride the jailbreak train ?
    1. trevorrawson's Avatar
      trevorrawson -
      I'm sorry if this has already been asked but i've been searching this post for an hour now and can't find the answer. I have a 3GS running the new IOS4. It has the old bootroom I think based off of the serial number being 38, I used the new pwnage tool to build a custom ipsw but everytime I put it in DFU mode I get error number 1600 and when it's in recovery mode it won't get past "preparing iphone for restore." As far as I know I should be able to jailbreak based on the fact that I have the old bootroom, have never used spirit and it was previously jailbroken on 3.1.3. Any help? Thanks in advance.

      Would using a USB hub work?
    1. mrrippey's Avatar
      mrrippey -
      my 3Gs got stuck in recovery but was able to get it back but upgraded to 3.1.3. when i tried to downgrade back to 3.1.2 (my shsh is on the saurik server) I kept getting a 1015 error. stuck on 3.1.3......any ideas?

      old bootrom but modem on 5.12.01 now (with 3.1.3)
    1. xattica's Avatar
      xattica -
      My 3GS just accepts the original Apple IOS4. Got my shsh on the saurik server, but can't restore using any other OS from Apple nor custom using Pwnage. Old bootrom but modem on 5.13 now
      Help!
    1. capttanhowdy's Avatar
      capttanhowdy -
      Quote Originally Posted by trevorrawson View Post
      I'm sorry if this has already been asked but i've been searching this post for an hour now and can't find the answer. I have a 3GS running the new IOS4. It has the old bootroom I think based off of the serial number being 38, I used the new pwnage tool to build a custom ipsw but everytime I put it in DFU mode I get error number 1600 and when it's in recovery mode it won't get past "preparing iphone for restore." As far as I know I should be able to jailbreak based on the fact that I have the old bootroom, have never used spirit and it was previously jailbroken on 3.1.3. Any help? Thanks in advance.

      Would using a USB hub work?
      I am having this exact issue and am on my 2nd day of combing thru 30 pages of this forum with noone being able to help Good luck
    1. drmias's Avatar
      drmias -
      Quote Originally Posted by capttanhowdy View Post
      I am having this exact issue and am on my 2nd day of combing thru 30 pages of this forum with noone being able to help Good luck
      You have to downgrade to a CUSTOM (Prefered) 3.1.2 OR 3.1.3 Version using your SHSH backup, and then upgrade to a Custom 4.0. Thats it! let know if you get any problem.

      press the Thanks! button if I deserve it
    1. capttanhowdy's Avatar
      capttanhowdy -
      Quote Originally Posted by drmias View Post
      You have to downgrade to a CUSTOM (Prefered) 3.1.2 OR 3.1.3 Version using your SHSH backup, and then upgrade to a Custom 4.0. Thats it! let know if you get any problem.

      press the Thanks! button if I deserve it
      my friend went swimming with it in his pocket (ok he got pushed in) And apple replaced it with this one for him. So this one hasnt been jb or unlocked before. Its a refurb iphone on 3.1.3 built in week 22 so should be old boot.
    1. drmias's Avatar
      drmias -
      Quote Originally Posted by capttanhowdy View Post
      my friend went swimming with it in his pocket (ok he got pushed in) And apple replaced it with this one for him. So this one hasnt been jb or unlocked before. Its a refurb iphone on 3.1.3 built in week 22 so should be old boot.
      Should be waiting for a new JB tool. Hopefully It'll be soon. If you are an unlocker, Make sure to google TinyUmbrella to backup your 4.0 SHSH to be able to use it then.
    1. JayWheelz's Avatar
      JayWheelz -
      Quote Originally Posted by mrrippey View Post
      my 3Gs got stuck in recovery but was able to get it back but upgraded to 3.1.3. when i tried to downgrade back to 3.1.2 (my shsh is on the saurik server) I kept getting a 1015 error. stuck on 3.1.3......any ideas?

      old bootrom but modem on 5.12.01 now (with 3.1.3)

      @mrrippey

      I had that problem but I used blackra1n after downgrading from 3.13 to 3.12. After you downgrade and your phones progress bar goes away. That error 1015 comes when you downgrade to 3.12. Use blackra1n. It will re-jailbreak the phone. You'll need to use Itunes after that to activate your phone again if you're on AT&T.

      I hope that helps
    1. drmias's Avatar
      drmias -
      to FIX ERROR 1015 download iReb from this Link:
      iH8sn0w.com | Jailbreak your iPod touches and iPhones
      and press on Fix Recovery Mode Loop, Choose 3G[S] and you're fine.

      Press Thanks if I deserve!
    1. IcyNuttY's Avatar
      IcyNuttY -
      Hey.. I Wanna Ask that if we jailbreaked using spirit , can we upgrade to 4 thn back to 3.1.3 and jailbreak using blackrain?
      Edit : and also whats the number for the old bootrom on 3GS?
    1. seandiego's Avatar
      seandiego -
      I am not going to read through 11 pages for my answer cus I am lazy so i am just going to ask...can I jailbreak my 3GS that is now running iOS4? It was previously jailbroken when it was iPhone OS 3.whatever using Geohots method.
    1. drmias's Avatar
      drmias -
      Quote Originally Posted by IcyNuttY View Post
      Hey.. I Wanna Ask that if we jailbreaked using spirit , can we upgrade to 4 thn back to 3.1.3 and jailbreak using blackrain?
      Edit : and also whats the number for the old bootrom on 3GS?
      The only way to jailbreak 3.1.3 is PwnageTools, and to use it (Restore to a Custom FW), if you're on 3.1.3 (JBed with Spirit) and have the hashes, then restore to a Custom 3.1.3 (JBed with PwnageTools) and then upgrade to a Custom (Pwnagetools) 4.0.


      Quote Originally Posted by seandiego View Post
      I am not going to read through 11 pages for my answer cus I am lazy so i am just going to ask...can I jailbreak my 3GS that is now running iOS4? It was previously jailbroken when it was iPhone OS 3.whatever using Geohots method.
      You should restore to 3.1.2, use blackra1n again, and then restore with CUSTOM 4.0 made with PwnageTools.

      press thanks if I helped.
    1. IcyNuttY's Avatar
      IcyNuttY -
      Quote Originally Posted by drmias View Post
      The only way to jailbreak 3.1.3 is PwnageTools, and to use it (Restore to a Custom FW), if you're on 3.1.3 (JBed with Spirit) and have the hashes, then restore to a Custom 3.1.3 (JBed with PwnageTools) and then upgrade to a Custom (Pwnagetools) 4.0.




      You should restore to 3.1.2, use blackra1n again, and then restore with CUSTOM 4.0 made with PwnageTools.

      press thanks if I helped.
      but what is the "old" bootrom? i have 359.3.2 or does it not matter on the MC132**?
    1. drmias's Avatar
      drmias -
      Sorry for you, you've got the new bootrom, geohot is willing to release a new tool for it, be patient. (I also have one, you're not alone).
    1. IcyNuttY's Avatar
      IcyNuttY -
      Sure Thing Dude... Thanks anyway.
    1. MJedi's Avatar
      MJedi -
      Quote Originally Posted by joe97 View Post
      help.BenM.at not working on JB 3GS 4.0--
      Thanks for trying that. What about the tethering patch that's on Cydia?
    1. rjd0717's Avatar
      rjd0717 -
      Has any1 that hacktivated the phone had any problems with push notification?