• Your favorite

    Apple

    ,

    iPhone

    ,

    iPad

    ,

    iOS

    ,
    Jailbreak
    , and
    Cydia
    site.
  • Redsn0w Updated. Adds Custom Boot Logos and Settings Simplification


    Just as all of us modders have finally gotten our untethered jailbreak on iOS 4.3.1 (except for the iPad 2,) and with a release of 4.3.2 looming, presumably to patch the untether created by @i0n1c, @MuscleNerd and the rest of the iPhone Dev Team have released redsn0w RC10 RC11, an upgrade from the original release for iOS 4.3.1, RC9.

    According to the dev team blog, redsn0w RC9 "enabled too many settings" for specific devices, confusing some users as they jailbroke their devices. The new update hopes to solve this confusion, simplifying the default settings, and then allowing users to choose settings as needed, as long as they know what they're doing.

    The update also adds compatibility for animated boot logos (which the team says is "more robust across all devices.") We first saw this option in the latest greenpois0n, the 4.2.1/4.2.6 jailbreak released by the chronic dev team, and later added to the windows-only jailbreak solution, sn0wbreeze, created by @ih8sn0w.

    @MuscleNerd reminds unlockers to only use custom IPSWs created with sn0wbreeze or pwnagetool that specifically preserve the baseboard. He has also mentioned over the past few days that 4.3.1 accidentally breaks ultrasn0w, and an update for the package is in the works. It should be noted that this update is simply for compatibility with current unlockable basebands. It will not unlock any baseboards that have not previously been unlocked.

    Lastly, he also reminds jailbreakers, that "unless mentioned otherwise in blog post, you should be able to run redsn0w on top of whatever [jailbreak] you have for that [firmware.]" So if you've already jailbroken on 4.3.1, feel free to run the new redsn0w on top of your current jailbreak to add custom boot logos.

    redsn0w RC11 is available for Windows and Mac, and can be downloaded at the dev team blog or at the following links:

    MMI Member OS X Mirror
    Megaupload
    Rapidshare

    MMi Member Windows Mirror
    Megaupload
    Rapidshare

    Source:
    @Musclenerd
    Dev Team Blog
    This article was originally published in forum thread: Redsn0w Updated. Adds Custom Boot Logos and Settings Simplification started by Matt Savoca View original post
    Comments 143 Comments
    1. OiPhoneMyiPhone's Avatar
      OiPhoneMyiPhone -
      Ok, I went to MANAGE, then clicked SETTINGS, changed to DEVELOPER, clicked DONE, SEARCHED for animate and found it. However, I have just one quick question before I install. The ANIMATE from BIGBOSS (SYSTEM) AUTHOR: Chronic-DEV INC. has a big red WARNING label stating that its for 4.2.1 untethered JB only GreenPois0n and non-monte.
      Is it safe to install this version of ANIMATE with the system I'm currently running?

      Thanks again for your help, its greatly greatly appreciated. First time i've ever blogged in a forum and it's awesome to get a response to my issue so quickly.

      Almost Stoked,

      OiPhone-MyiPhone

      Nevermind, I scrolled further down and say that it states its ok for RedSn0w. Gonna install now.

      Alrighty well, I clicked on install for ANIMATE, waited while it was doing its thing and I got an error message saying...

      TRYING TO OVERWRITE `/USR/BIN/ANIMATE', WHICH IS ALSO IN
      PACKAGE IMAGEMAGICK

      SUB-PROCESS/USR/BIN/DPKG RETURNED AN ERROR CODE (1)
    1. thazsar's Avatar
      thazsar -
      Quote Originally Posted by OiPhoneMyiPhone View Post
      Ok, I went to MANAGE, then clicked SETTINGS, changed to DEVELOPER, clicked DONE, SEARCHED for animate and found it. However, I have just one quick question before I install. The ANIMATE from BIGBOSS (SYSTEM) AUTHOR: Chronic-DEV INC. has a big red WARNING label stating that its for 4.2.1 untethered JB only GreenPois0n and non-monte.
      Is it safe to install this version of ANIMATE with the system I'm currently running?

      Thanks again for your help, its greatly greatly appreciated. First time i've ever blogged in a forum and it's awesome to get a response to my issue so quickly.

      Almost Stoked,

      OiPhone-MyiPhone

      Nevermind, I scrolled further down and say that it states its ok for RedSn0w. Gonna install now.

      Alrighty well, I clicked on install for ANIMATE, waited while it was doing its thing and I got an error message saying...

      TRYING TO OVERWRITE `/USR/BIN/ANIMATE', WHICH IS ALSO IN
      PACKAGE IMAGEMAGICK

      SUB-PROCESS/USR/BIN/DPKG RETURNED AN ERROR CODE (1)
      Okay, then u already have a 'version' of animate installed.
      -Go to MANAGE
      -Click PACKAGES
      -Find: animate
      -Click MODIFY (top right)
      -Reinstall 'animate'

      Let us know if that works instead. If it doesn't, you can try Uninstalling your current version of 'animate' and then INSTALL the version of 'animate' that you found in Cydia. ***I have not tested the above idea but if all else fails, you can rerun redsn0w to get redsn0w's version of 'animate' back on ur phone. Rerunning redsn0w 'shouldn't' cause your phone to loose anything.***
    1. OiPhoneMyiPhone's Avatar
      OiPhoneMyiPhone -
      Ok so here is where I am so far now....

      I had already tried the "MODIFY and REINSTALL of 'animate' the day before yesterday and it didnt work. So today after reading your last post I did the next step and Uninstalled the current version of 'animate' and then INSTALLED the version that was in Cydia, and walla! the Bootlogo tab now appeared in my Settings section and I was able to use the Red Dragon Bootlogo. But.... lol

      The version of 'animate' I originally had was part of the package install of 'Imagemagick' and so I had to uninstall imagemagick in order to get rid of that version of 'animate' so that I could install the Cydia version.

      After I rebooted to see if Red Dragon Bootlogo, I went back into Cydia to reinstall 'Imagemagick' and just like before but opposite, I get the same error code for 'imagemagick' that I had before with 'animate'

      From what I could tell, 'imagemagick' is part of Telesphoreo Tangelo which looks to be part of the Cydia download, but what do i know? lol. I'm wondering what other features will now be affected by not having 'imagemagick' installed. Hopefully none or something that is much less of a want or necessity than bootlogos.

      Any thoughts, ideas or comments?

      If anything, THANK YOU for your patience and helping me fix the bootlogo issue.


      Gratefully Bootlogo-in again,

      OiPhone-MyiPhone
    1. Kaospassageraren's Avatar
      Kaospassageraren -
      I've used pwnagetool can i just run redsnow over it without cydia install??
    1. confucious's Avatar
      confucious -
      Yes
    1. roraniel's Avatar
      roraniel -
      So to install RC11 over top of RC9 I just download and run RC11, navigate to the 4.3.1 firmware and go from there? No need to restore in iTunes first correct?

      Also if everything is fine and functioning correctly with RC9 is there a need to update to RC11 if I am not interested in animated boot logos?
    1. thazsar's Avatar
      thazsar -
      Quote Originally Posted by roraniel View Post
      So to install RC11 over top of RC9 I just download and run RC11, navigate to the 4.3.1 firmware and go from there? No need to restore in iTunes first correct?

      Also if everything is fine and functioning correctly with RC9 is there a need to update to RC11 if I am not interested in animated boot logos?
      Correct. If u don't want bootlogos then leave your phone as it is.
    1. thazsar's Avatar
      thazsar -
      Quote Originally Posted by OiPhoneMyiPhone View Post
      Ok so here is where I am so far now....

      I had already tried the "MODIFY and REINSTALL of 'animate' the day before yesterday and it didnt work. So today after reading your last post I did the next step and Uninstalled the current version of 'animate' and then INSTALLED the version that was in Cydia, and walla! the Bootlogo tab now appeared in my Settings section and I was able to use the Red Dragon Bootlogo. But.... lol

      The version of 'animate' I originally had was part of the package install of 'Imagemagick' and so I had to uninstall imagemagick in order to get rid of that version of 'animate' so that I could install the Cydia version.

      After I rebooted to see if Red Dragon Bootlogo, I went back into Cydia to reinstall 'Imagemagick' and just like before but opposite, I get the same error code for 'imagemagick' that I had before with 'animate'

      From what I could tell, 'imagemagick' is part of Telesphoreo Tangelo which looks to be part of the Cydia download, but what do i know? lol. I'm wondering what other features will now be affected by not having 'imagemagick' installed. Hopefully none or something that is much less of a want or necessity than bootlogos.

      Any thoughts, ideas or comments?

      If anything, THANK YOU for your patience and helping me fix the bootlogo issue.


      Gratefully Bootlogo-in again,

      OiPhone-MyiPhone
      Imagemagick might just be another file associated w/ the redsn0w bootlogo activator. I don't have 4.3.1 yet but I doubt imagemagick is used for anything else but bootlogos.
    1. confucious's Avatar
      confucious -
      Quote Originally Posted by roraniel View Post
      So to install RC11 over top of RC9 I just download and run RC11, navigate to the 4.3.1 firmware and go from there? No need to restore in iTunes first correct?

      Also if everything is fine and functioning correctly with RC9 is there a need to update to RC11 if I am not interested in animated boot logos?
      If you're not interest in animated BootLogos and it works then stick with RC9.
      If you want animated Bootlogos you need RC12 not RC11.
    1. Grimlet's Avatar
      Grimlet -
      I JB'd with RC12, downloaded animate from Cydia but still have no animated boot logos. I do have the option in Settings and I have selected the Arc Reactor Apple boot logo. I have reinstalled animate as developer and also uninstalled and reinstalled with no changes. Any suggestions?
    1. thazsar's Avatar
      thazsar -
      Quote Originally Posted by Grimlet View Post
      I JB'd with RC12, downloaded animate from Cydia but still have no animated boot logos. I do have the option in Settings and I have selected the Arc Reactor Apple boot logo. I have reinstalled animate as developer and also uninstalled and reinstalled with no changes. Any suggestions?
      When u jailbroke, did u select Bootlogo Animation in redsn0w?

      If not, rerun redsn0w with that checked
    1. Grimlet's Avatar
      Grimlet -
      Yes, that was the only thing I had checked off.
    1. thazsar's Avatar
      thazsar -
      Quote Originally Posted by Grimlet View Post
      Yes, that was the only thing I had checked off.
      Did u try to uninstall and reinstall animate then REBOOT? then get an animated Bootlogo.
    1. Grimlet's Avatar
      Grimlet -
      Doh! I forgot about rebooting. It works now 
    1. thazsar's Avatar
      thazsar -
      Quote Originally Posted by Grimlet View Post
      Doh! I forgot about rebooting. It works now 
      Sweet!
    1. Grimlet's Avatar
      Grimlet -
      One more question. Is the boot logo only for when you reboot or is it supposed to show when you respring as well?
    1. Simon's Avatar
      Simon -
      Just for when you reboot
    1. confucious's Avatar
      confucious -
      If you have no custom respiring logo (eg the one used by sbsettings) then the last image of the animated custom boot logo shows as a static image when you respring.
    1. IcyNuttY's Avatar
      IcyNuttY -
      im still confused after reading , so i would like to ask , is every iphone able to use the custom boot logo?