• Your favorite

    Apple

    ,

    iPhone

    ,

    iPad

    ,

    iOS

    ,
    Jailbreak
    , and
    Cydia
    site.
  • Redsn0w Updated. Adds Custom Boot Logos and Settings Simplification


    Just as all of us modders have finally gotten our untethered jailbreak on iOS 4.3.1 (except for the iPad 2,) and with a release of 4.3.2 looming, presumably to patch the untether created by @i0n1c, @MuscleNerd and the rest of the iPhone Dev Team have released redsn0w RC10 RC11, an upgrade from the original release for iOS 4.3.1, RC9.

    According to the dev team blog, redsn0w RC9 "enabled too many settings" for specific devices, confusing some users as they jailbroke their devices. The new update hopes to solve this confusion, simplifying the default settings, and then allowing users to choose settings as needed, as long as they know what they're doing.

    The update also adds compatibility for animated boot logos (which the team says is "more robust across all devices.") We first saw this option in the latest greenpois0n, the 4.2.1/4.2.6 jailbreak released by the chronic dev team, and later added to the windows-only jailbreak solution, sn0wbreeze, created by @ih8sn0w.

    @MuscleNerd reminds unlockers to only use custom IPSWs created with sn0wbreeze or pwnagetool that specifically preserve the baseboard. He has also mentioned over the past few days that 4.3.1 accidentally breaks ultrasn0w, and an update for the package is in the works. It should be noted that this update is simply for compatibility with current unlockable basebands. It will not unlock any baseboards that have not previously been unlocked.

    Lastly, he also reminds jailbreakers, that "unless mentioned otherwise in blog post, you should be able to run redsn0w on top of whatever [jailbreak] you have for that [firmware.]" So if you've already jailbroken on 4.3.1, feel free to run the new redsn0w on top of your current jailbreak to add custom boot logos.

    redsn0w RC11 is available for Windows and Mac, and can be downloaded at the dev team blog or at the following links:

    MMI Member OS X Mirror
    Megaupload
    Rapidshare

    MMi Member Windows Mirror
    Megaupload
    Rapidshare

    Source:
    @Musclenerd
    Dev Team Blog
    This article was originally published in forum thread: Redsn0w Updated. Adds Custom Boot Logos and Settings Simplification started by Matt Savoca View original post
    Comments 143 Comments
    1. BlackRaider's Avatar
      BlackRaider -
      rc12, app store icon disappears. wow.
    1. Simon's Avatar
      Simon -
      My app store icon is still there after it. That's odd yours isn't.
    1. BlackRaider's Avatar
      BlackRaider -
      the hide icon option on sbsettings didn't do anything either. but no big deal, i needed to reflash anyways. my music kept gettting deleted so.
    1. dread33's Avatar
      dread33 -
      So if i restore my iphone 4 to 4.3.1 with my custom firmware from sn0wbreeze, will ultrasnow unlock my iphone so that I can usd it?
    1. Turnamental's Avatar
      Turnamental -
      Quote Originally Posted by confucious View Post
      Gracias seniõr!

      This worked flawlessly on my iPhone 4.
    1. confucious's Avatar
      confucious -
      Quote Originally Posted by dread33 View Post
      So if i restore my iphone 4 to 4.3.1 with my custom firmware from sn0wbreeze, will ultrasnow unlock my iphone so that I can usd it?
      If you hava a BB that is unlockable bu UltraSn0w then you will have to wait until the upadate to make it compatable with 4.31 is released.

      It shouldn't be a long wait....
    1. Zlik's Avatar
      Zlik -
      I grabbed animate from Cydia afterwards (seeing nothing in settings), and now it works.
    1. confucious's Avatar
      confucious -
      Installing an animated boot logo should install animate as well if you don't already have it.
    1. Just Dummy's Avatar
      Just Dummy -
      Works sweet thank you. I didn't realize as well as for booting it also is now my respring image.
    1. Blochead21's Avatar
      Blochead21 -
      I need some help i can't get this to work. I jailbroke with the rc9 and wanted to get the boot logos for my ipod 3rd gen on 4.3.1.

      So i tried re-running rc12 over the previous jailbreak and it wouldn't work. So i did a fresh restore and the same thing again.

      I have it in XP compatibility mode, and i run it as admin, and i hold the home button the whole time. It keeps crashing on uploading ramdisk.

      Why wont this work??
    1. ninthchamber99's Avatar
      ninthchamber99 -
      Can someone please either instruct or point me in the direction of how to SSH a boot logo onto your iDevice (I am doing my iPad first). When I search on MMI, I only see results for the past like using LogoMe but I want to upload one I downloaded from MMI. I see people talking about 0.png-9.png but I dont know where to add them and how they should be named properly.

      Edit: I just downloaded the one I wanted from Cydia. But I would still like to know the file location and why are all the animations in landscape instead of portiat? can this be changed?
    1. thazsar's Avatar
      thazsar -
      Quote Originally Posted by ninthchamber99 View Post
      Can someone please either instruct or point me in the direction of how to SSH a boot logo onto your iDevice (I am doing my iPad first). When I search on MMI, I only see results for the past like using LogoMe but I want to upload one I downloaded from MMI. I see people talking about 0.png-9.png but I dont know where to add them and how they should be named properly.

      Edit: I just downloaded the one I wanted from Cydia. But I would still like to know the file location and why are all the animations in landscape instead of portiat? can this be changed?
      /Library/Bootlogos/YOURLOGOFOLDER/0.png-x.png

      *0.png should be the original Apple logo but it doesn't have to be

      Respring and that's it!
    1. axlf97's Avatar
      axlf97 -
      Ok I just updated from RC11 to 12 and it screwed my signal bars up big time now all I get is one or two bars.
      I am on latest firmware and boot rom can someone tell me if there is a fix for this.
    1. Amraam's Avatar
      Amraam -
      Personally I don't understand the popularity of different boot logos. 50% of the time, when I had one and rebooted my iphone 4, it would boot into safe mode.


      Question: I'm on 4.2.1 greenpois0n. Can I just upgrade in iTunes to 4.3.1 (wiping the greenpois0n JB), and then jailbreak with redsn0w rc11? I was thinking of this method, simpyl so SMS and app saves etc won't get lost (I'm only half way through broken sword 2 ) Or is it strongly recommended to restore to 4.3.1 first?
    1. Simon's Avatar
      Simon -
      Quote Originally Posted by Amraam View Post
      Personally I don't understand the popularity of different boot logos. 50% of the time, when I had one and rebooted my iphone 4, it would boot into safe mode.


      Question: I'm on 4.2.1 greenpois0n. Can I just upgrade in iTunes to 4.3.1 (wiping the greenpois0n JB), and then jailbreak with redsn0w rc11? I was thinking of this method, simpyl so SMS and app saves etc won't get lost (I'm only half way through broken sword 2 ) Or is it strongly recommended to restore to 4.3.1 first?
      Yes, you can do that and should be fine. Use the latest redsnow 0.9.6rc12 though.
    1. Amraam's Avatar
      Amraam -
      Quote Originally Posted by x98car View Post
      Yes, you can do that and should be fine. Use the latest redsnow 0.9.6rc12 though.

      Cheers bud, I'll do that when I get home from work
    1. Kupe's Avatar
      Kupe -
      Wow- do I regret this. redsn0w has been a disaster.

      My iPhone 3gs has been running 4.2.1 jailbroken with Greenpoison for a couple months. Rock solid.

      Tonight decided to upgrade to 4.3.1 and JB with redsn0w 0.9.6rc12. Upgrade to 4.3.1 went fine in iTunes. That was hours ago!

      Since then, have run redsn0w again and again and again and keep getting "Unexpected Error" every time after entering the Power-Home-Power DFU sequence. I've rebooted the phone and computer so many times tonight I've lost count. Changed USB ports as suggested, etc.

      I'm running Snow Leopard 10.6.6 on an Intel iMac. Has anyone successfully run redsn0w in this configuration? Which BTW is probably the most common iMac configuration out there.

      I'm not new at this...something is really messed up! Ideas?

      Thanks!

      Kupe

      EDIT: It only gets worse. After each of these Unexpected Errors, the phone remains in Recovery Mode. I kick it out of Recovery with Tiny Umbrella, but iTunes keeps seeing it as a phone in Recovery. Tiny Umbrella "Fix Recovery" doesn't repair this, and I'm on my second full iTunes recovery tonight- i.e. 1 hour plus each. WTF? Also tried redsn0w 0.9.6rc11 and same result.
    1. OiPhoneMyiPhone's Avatar
      OiPhoneMyiPhone -
      I am using an iPhone 4 with iOS 4.3.1 firmware. I have the latest RedSn0w 0.9.6rc12 and the new Cydia. However, there is no Bootlogo tab in my Settings section in order for me to checkmark which bootlogo I wish to use. I downloaded Red Dragon bootlogo from Cydia and when I rebooted my iPhone I got the usual Apple logo.
      I was previously using Greenpois0n on iOS 4.2.1 and loved all the choices for bootlogos, they pretty much all worked great, but I'm stumped now. Does anybody know how I can fix this issue? Thanks ahead of time if you can.

      Stumped,

      OiPhone-MyiPhone
    1. thazsar's Avatar
      thazsar -
      Quote Originally Posted by OiPhoneMyiPhone View Post
      I am using an iPhone 4 with iOS 4.3.1 firmware. I have the latest RedSn0w 0.9.6rc12 and the new Cydia. However, there is no Bootlogo tab in my Settings section in order for me to checkmark which bootlogo I wish to use. I downloaded Red Dragon bootlogo from Cydia and when I rebooted my iPhone I got the usual Apple logo.
      I was previously using Greenpois0n on iOS 4.2.1 and loved all the choices for bootlogos, they pretty much all worked great, but I'm stumped now. Does anybody know how I can fix this issue? Thanks ahead of time if you can.

      Stumped,

      OiPhone-MyiPhone
      Try this:
      -go to MANAGE
      -click SETTINGS (top left)
      -change to DEVELOPER
      -click DONE (top right)
      -SEARCH for and install: animate
      -Respring and see if BOOTLOGOS now shows up in Settings
      -if it does show up but ur Bootlogo doesn't work on a Reboot, reinstall your Bootlogo again.

      Let us know