• Your favorite

    Apple

    ,

    iPhone

    ,

    iPad

    ,

    iOS

    ,
    Jailbreak
    , and
    Cydia
    site.
  • Redsn0w Updated. Adds Custom Boot Logos and Settings Simplification


    Just as all of us modders have finally gotten our untethered jailbreak on iOS 4.3.1 (except for the iPad 2,) and with a release of 4.3.2 looming, presumably to patch the untether created by @i0n1c, @MuscleNerd and the rest of the iPhone Dev Team have released redsn0w RC10 RC11, an upgrade from the original release for iOS 4.3.1, RC9.

    According to the dev team blog, redsn0w RC9 "enabled too many settings" for specific devices, confusing some users as they jailbroke their devices. The new update hopes to solve this confusion, simplifying the default settings, and then allowing users to choose settings as needed, as long as they know what they're doing.

    The update also adds compatibility for animated boot logos (which the team says is "more robust across all devices.") We first saw this option in the latest greenpois0n, the 4.2.1/4.2.6 jailbreak released by the chronic dev team, and later added to the windows-only jailbreak solution, sn0wbreeze, created by @ih8sn0w.

    @MuscleNerd reminds unlockers to only use custom IPSWs created with sn0wbreeze or pwnagetool that specifically preserve the baseboard. He has also mentioned over the past few days that 4.3.1 accidentally breaks ultrasn0w, and an update for the package is in the works. It should be noted that this update is simply for compatibility with current unlockable basebands. It will not unlock any baseboards that have not previously been unlocked.

    Lastly, he also reminds jailbreakers, that "unless mentioned otherwise in blog post, you should be able to run redsn0w on top of whatever [jailbreak] you have for that [firmware.]" So if you've already jailbroken on 4.3.1, feel free to run the new redsn0w on top of your current jailbreak to add custom boot logos.

    redsn0w RC11 is available for Windows and Mac, and can be downloaded at the dev team blog or at the following links:

    MMI Member OS X Mirror
    Megaupload
    Rapidshare

    MMi Member Windows Mirror
    Megaupload
    Rapidshare

    Source:
    @Musclenerd
    Dev Team Blog
    This article was originally published in forum thread: Redsn0w Updated. Adds Custom Boot Logos and Settings Simplification started by Matt Savoca View original post
    Comments 143 Comments
    1. Just Dummy's Avatar
      Just Dummy -
      I did a fresh install as a new phone of 4.3.1 and the newest RC 11 Redsn0w and the boot logo still won't work. I initially tried to overwrite my previous jb on the same firmware with no result and hoped a clean install would cure it. So no luck? A few others have tried this with the same results. Anyone get it working on an Ip4?
    1. thewhiterabbit9's Avatar
      thewhiterabbit9 -
      This only for AT&T phones or does it work on Verizon too? Have had some issues with Greenpoison...
    1. jonathan1683's Avatar
      jonathan1683 -
      I saw this asked but no one answered if there is still the signal bar issue while preserving the baseboard.
    1. farfromovin's Avatar
      farfromovin -
      Yeah, bootlogo's not working here either. Picture or animated logos, nothing? They show up in the settings and I can preview them, but not when I restart... FWIW, I Redsn0w'd on top of Sundays Redsn0w lol... Oh well. I'm not even going to bother with the clean install...
    1. twitchee3's Avatar
      twitchee3 -
      Quote Originally Posted by farfromovin View Post
      Yeah, bootlogo's not working here either. Picture or animated logos, nothing? They show up in the settings and I can preview them, but not when I restart... FWIW, I Redsn0w'd on top of Sundays Redsn0w lol... Oh well. I'm not even going to bother with the clean install...
      Same situation here... iPhone 4, 4.3.1. JB'ed with Redsn0w on Sunday, re-ran rc11 today for boot functionality: fail.
    1. Admlostsailor's Avatar
      Admlostsailor -
      Quote Originally Posted by twitchee3 View Post
      Same situation here... iPhone 4, 4.3.1. JB'ed with Redsn0w on Sunday, re-ran rc11 today for boot functionality: fail.
      Yep, same here. applied rc11 on top of my rc9 from Sunday. No Go. did a full restore and re-redsn0w'd. Nothing.
    1. Turnamental's Avatar
      Turnamental -
      Quote Originally Posted by Admlostsailor View Post
      Yep, same here. applied rc11 on top of my rc9 from Sunday. No Go. did a full restore and re-redsn0w'd. Nothing.
      +1
    1. confucious's Avatar
      confucious -
      They don't work for me either, not something that bothers me but I might see if I can figure it out.

      I'll ask around.
    1. discostar's Avatar
      discostar -
      Jailbreak, jailbreak, jailbreak. we're never going to hear the word "unlock" ever again are we? :-/
    1. metaljay's Avatar
      metaljay -
      Any news on the boot logos not working?
    1. confucious's Avatar
      confucious -
      Give us a chance! MN wasn't aware it wasn't working for everyone until I let him know and he does have other things to do. I'm sure it will be resolved but it probably isn't his highest priority.
      If it doesn't work, please be patient.
    1. eddietah's Avatar
      eddietah -
      Thanks for sharing
    1. metaljay's Avatar
      metaljay -
      Chill out lol, I read that some people have had success going to rc10 then rc11
      Have yet to try
    1. marko111's Avatar
      marko111 -
      dumb question, but if one was to redo the JB with the new version, where do we find animated boot screens?
    1. Amadomon's Avatar
      Amadomon -
      Quote Originally Posted by ninthchamber99 View Post
      I feel so left behind. My 3GS is still on 4.0!!! It is has been working PERFECTLY FINE and I really never saw the need to upgrade. So let me ask you all, should I just bite the bullet and upgrade to 4.3.1 or just stick with 4.0? I have all SHSH blobs saved so that is not an issue, I guess I have been lazy and never saw the need to upgrade.

      And just to make sure I am reading this correctly, this is an untethered JB right?
      I have the exact same setup and feel no need to upgrade. Tethering? Got it. Gamecenter? Not interested. Got the PDF patch, so no code injection. Got a nice unlockable baseband, saved blobs all over the place, no crazy iPad bb...can't think of a reason to mess with a perfectly-working, thoroughly-tweaked phone, except for the fun of it. So far, not compelling enough.
    1. Just Dummy's Avatar
      Just Dummy -
      Quote Originally Posted by marko111 View Post
      dumb question, but if one was to redo the JB with the new version, where do we find animated boot screens?
      Look on Cydia and search boot. Most all come with the animate package required but yet to work on 4.3.1
    1. confucious's Avatar
      confucious -
      Try the Android boot logo from the BigBoss repo first to make sure it works.
      In settings you should find a new option 'BootLogo' under extensions once you have installed the bootlogo from cydia. You will have to select the boot logo there
    1. InsecureSpike's Avatar
      InsecureSpike -
      Quote Originally Posted by confucious View Post
      Try the Android boot logo from the BigBoss repo first to make sure it works.
      In settings you should find a new option 'BootLogo' under extensions once you have installed the bootlogo from cydia. You will have to select the boot logo there
      tanks for the help mate, but that still don't work
    1. confucious's Avatar
      confucious -
      Doesn't work for me either.
      The problem is being looked into. That one should work and now it has been confirmed people have problems with it hopefully it can be fixed.
      Other Boot logos might not work for other reasons but that one should work.
    1. Turb02's Avatar
      Turb02 -
      I posted on MN's twitter yesterday about this (20 hours ago) to inform him of this issue. Now I doubt he reads every tweet but he was informed...by this lowly fella.