• Your favorite

    Apple

    ,

    iPhone

    ,

    iPad

    ,

    iOS

    ,
    Jailbreak
    , and
    Cydia
    site.
  • 3GS Jailbreak - redsn0w 0.8 - DevTeam Style


    While geohot may have beaten the DevTeam to a 3GS jailbreak, they were not far behind - redsn0w 0.8 (the DevTeam's official jailbreak tool for all 3.0+ iDevices) has just been released, and is compatible with the iPhone 3GS.

    Oh, and check it out - works on Linux too!

    EDIT: To clarify, this is NOT compatible with 3.1 - 3.0 only.

    redsn0w is a easy to use, multi-platform, multi-device jailbreaking and unlocking tool for the iPhone 2G (original iPhone), the iPhone 3G/3GS and also the iPod touch(1st generation and second generation). Currently it is available for Windows, Mac OS X and Linux.
    Windows Guide HERE
    OS X Guide HERE


    The downloads are available via:
    This article was originally published in forum thread: 3GS Jailbreak - redsn0w 0.8 - DevTeam Style started by Kyle Matthews View original post
    Comments 164 Comments
    1. Real_Iphonecrazy's Avatar
      Real_Iphonecrazy -
      is that 0.7.2 you are referring to? its the only other one i see
      Yeh I'm prety sure that's the previous version. Check out the windows 3g/FW3.0 tutorial or mac tutorial, whatever suits you, just search you'll find it on here somewhere
    1. PCeasar's Avatar
      PCeasar -
      Quote Originally Posted by Real_Iphonecrazy View Post

      @PCeasar saurik is a part of the Dev Team but I think it was more of a coincidence, I can't see any benefits to him holding back on winterboard until redsn0w was released
      Ahh that makes sense, I thought I heard that somewhere before that he was part of the Dev team.....I guess there wasn't that much time between purplera1n and Redsn0w 0.8 so yea I agree coincidence. Its just felt like forever waiting on the JB and winterboard.
    1. Real_Iphonecrazy's Avatar
      Real_Iphonecrazy -
      @PCeasar, I agree when your waiting it does seem like forever, but if you put it in perspective this was the fasted jailbraik for a new device by a long way. Thanks to geohot, chronic dev team and not forgeting the dev team.
    1. StealthBravo's Avatar
      StealthBravo -
      I love me some purplera1n
    1. Real_Iphonecrazy's Avatar
      Real_Iphonecrazy -
      @StealthBravo what's the modmyi platinum image and what's a premium account all about?
    1. ebentley's Avatar
      ebentley -
      It works. I use it with Sling Player HD
    1. imilad's Avatar
      imilad -
      Even tho the dev team has been great in the past, I am sticking to my GEO Jailbreak,,,, RUNS FLAWLESS ON MY 3GS and the ONE BUTTON MAKE IT RAIN IS OFF THE CHAIN!!!
    1. Jorgegato's Avatar
      Jorgegato -
      Hi I just installed the jailbreak in my iphone 3Gs the phone is unlocked i put the tmobile sim and I have no service do you know what to do now? any help would be very appreciated Tks.
    1. StealthBravo's Avatar
      StealthBravo -
      ^ Is it factory unlocked or did you run ultrasn0w to unlock?
    1. fsdpmc's Avatar
      fsdpmc -
      any help after ultrasnow wifi lost uninstall wifi back.....jailbreak with redsnow 0.8 it went well...every thing is fine except ultra snow any suggestions.....please?
    1. Jorgegato's Avatar
      Jorgegato -
      I run ultrasnow to unlocked
    1. leletyM3's Avatar
      leletyM3 -
      Quote Originally Posted by fsdpmc View Post
      any help after ultrasnow wifi lost uninstall wifi back.....jailbreak with redsnow 0.8 it went well...every thing is fine except ultra snow any suggestions.....please?
      Make sure you turn off 3G under network and restart your iphone...
    1. fsdpmc's Avatar
      fsdpmc -
      I did that but no success..... any otherway plz....to get wifi back after installing ultrasnow......i have 3g too but it works great on that.....BUT NOT ON 3GS.......
    1. happymonkey's Avatar
      happymonkey -
      Quote Originally Posted by fsdpmc View Post
      I did that but no success..... any otherway plz....to get wifi back after installing ultrasnow......i have 3g too but it works great on that.....BUT NOT ON 3GS.......
      Try this guide here Alternative Working Solution For 3GS Network Signal and Wifi Issues - Hackint0sh

      worked for me!
    1. dbet21's Avatar
      dbet21 -
      Has anyone gotten any word yet on voip's for the 3gs now that they arent working? or have found some type of loop hole for skype over 3g?
    1. ChrisRC1985's Avatar
      ChrisRC1985 -
      I have a 3Gs, and I am troubled as to where I can browse for the .ipsw file
      where am I suppose to download the firmware from, I have searched the internet, but
      the firmware are for older versions of the iphone.
      what should I do??
    1. dale1v's Avatar
      dale1v -
      So,
      are you all saying that purplera1n's coding is better only because _you_ used it and don't want to look stupid? Or is it because you actually know how both of the methods of jailbreak work and sat down to see how they were executed? I remember people saying how ZiPhone was the best at one point in time...just sayin'...
    1. Brick James's Avatar
      Brick James -
      I could not get this to install properly, so I installed purplera1n's. So far purplera1n's install perfectly. One question I would ask everyone is; Are you Jail breaking a clean 3G S. Because at 1st when I got my phone I did a sync that used ALL the information from my older 3G phone. Then I thought Sh!t, just sync it as a new Iphone. I could always get my contacts because that was synced with Office. So, maybe if you are having trouble with some of your programs, You might just wanna start fresh. Its just a thought.
    1. Neo-Tech's Avatar
      Neo-Tech -
      I recommend the same as well, whenever you restore to a new firmware as big as 3.0, restore from a fresh one to eliminate any problems from backups.
    1. lilskaterpunk's Avatar
      lilskaterpunk -
      Does anyone have any problems with MMS after jailbreaking with Redsn0w 0.8? Its not sending anymore for me. Any ideas? OR could it be something else causing MMS issues? SBsettings?